Skip to content
U

New Member

 • 

1 Message

Wed, Dec 29, 2021 5:22 PM

Cannot enter E911 information....

I start the desktop application. I sign in and can see all the details in the background behind the E911 popup and it is all good. BUT

I CANNOT CONFIRM MY ADDRESS WHEN ENTERED INTO E911......

I have called in about this previously. I am stuck on multiple users accounts. I am not DAFT as I am 30 year I.T. vet. I know how to type in an address too being 51 years of age and having done this once or twice in my lifetime.

No matter what combination / trick / voodoo / or chicken blood I use your app will NOT confirm the address as entered IDENTICALLY as my account shows in the website. We do exist at the given address..... the given address is REAL and we pay handsomely for it.  

ZERO response to my original ticket and now I have multiple users who cannot use their application because your app denies that our address is valid - and I cannot bypass it to just use the phone app in the meantime.

BTW..... before you tell me to login to my admin account online and fix it there..... the tech on the phone tried that on the original ticket and it also does not allow us to enter E911 information.


I want EVERYONE to know this is a bad safety issue as it pertains to my users being able to call 911 in case of an emergency. This is required by law and it is BROKEN AF on Comcast Business Desktop App.

I NEED A SOLUTION TODAY NOT TOMORROW.

Official Employee

 • 

29 Messages

5 m ago

Hi, @user_c69db2. Thank you for bringing this to our attention. I appreciate the effort you've put in so far to resolve this issue. Since you've already had tickets opened, I want to look into your account specifically and see what steps if any have been taken on those tickets. I'll ask that you send us a private message including your name, business name, and address to start.

Steps to send a Private Message:

Click "Sign In" if necessary

Click the "Peer to peer chat" icon or https://comca.st/3EEUFFw

Click the "New message" (pencil and paper) icon

The "To:" line prompts you to "Type the name of a person". Instead, type "Comcast Business" there

- As you are typing a drop-down list appears. Select "Comcast Business" from that list

- A "Comcast Business" graphic replaces the "To:" line

Type your message in the text area near the bottom of the window

Press Enter to send it

New Contributor

 • 

3 Messages

2 m ago

We are having the same problem with a user's new laptop. How is it helpful, Comcast_Christina, to solve user_c69db2's issue through private chat? What is the point of this help forum if not to provide answers so we don't have to call in?

New Contributor

 • 

1 Message

1 m ago

Having this same issue on macOS Monterey, the app will not get past the E911 confirmation rendering it unusable. I tried on the same Macbook through Windows (via Parallels) and it confirmed the address just fine. I also tried on an older iMac running High Sierra and it also confirmed the E911 address just fine. So, it appears there is some kind of bug preventing this from working with Monterey specifically. If you could look into this and try to provide a fix I would appreciate it.

Thanks

Official Employee

 • 

7 Messages

Hello there, and thank you for bringing this to our attention through our Forums! I understand you've been experiencing trouble, while trying to secure your E911 settings, and I can imagine the urgency behind this. Rest assured; you're with the pros, and our Digital Care Team is here to help, every step of the way! 

 

Before we begin, can you please send us a private message, including your full name, and your full address? You can do so, by clicking on the chat icon, in the top right hand corner of your screen, and once you click on that icon, you should be able to search "Xfinity Support", which should then give you the ability to send us a message. Thank you in advance, and I look forward to speaking with you!