Equipment (Modems,Gateways)
Modems, Gateways, and Networking Devices
Male IT Specialist Holds Laptop and Discusses Work with Female Server Technician. They're Standing in Data Center, Rack Server Cabinet is Open.
Highlighted
Occasional Visitor

cusadmin not a valid username on our DPC3939B anymore

I really don't understand why the default user/password randomly changes on ComCast hardware. This happened on our old SMC too. It's kind of anoying. I have a script that logs our signals into an RRD graph and I noticed it stopped working a few days ago because the logon credentioals stopped working.

 

When I try to login by hand using cusadmin/highspeed it tells me the username is invalid.

 

Why does ComCast think it's okay to randomly change passwords on the equipment? This is biz service not residential.

0 Kudos
7 ACCEPTED SOLUTIONS

Accepted Solutions
Highlighted
Trusted Forum Contributor

Re: cusadmin not a valid username on our DPC3939B anymore

Hello Noel and welcome,

 

Comcast does not change their default customer login credentials, however, customers frquently do. It is always necessary to use a computer with an Ethernet cable plugged directly into any of the rear Lanports 1-4. The standard browser address 10.1.10.1n unless reprogrammed by the customer,  and username=cusadmin, password=highspeed.

 

 

If your Comcast Gateway (CG) does not use a staticIP or has no port forwarding, triggering, etc. setup configuration parameters, i.e. just bland DHCP server implementation, then you can depress the little black reset button on the rear of the CG for 15 seconds minimum, and your factory defaults will be restored, including your default login credentials.

 

Hope this helps you out. 

View solution in original post

Highlighted
Visitor

Re: cusadmin not a valid username on our DPC3939B anymore

If you are trying to access it from the Web - or outside of the LAN - you will get that message.

 

 

I am not sure how your script was running previously or how you are testing it - but that might not be the reason your script stopped working.

 

If you are checking from the outside - it will tell you that the "cusadmin" is not valid.

 

Let me know if this helps at all bud... good luck.

 

-Joe

Internet Exploder - Version 20.15 - Xfinity & Beyond! - Comcast 4 Life

View solution in original post

0 Kudos
Highlighted
Occasional Visitor

Re: cusadmin not a valid username on our DPC3939B anymore

I wrote a script that programatically accesses the modem and logs the stats into an RRD graph. It's obvious I know these basic sugestions that are being given. I am the only one with access to the modem so I'm the only one that would change the password and I have not changed the password. We have been fighting with bad service for about a month now so I am litterally checking my RRD graphs every few hours. My script didn't forget our password out of the blue or change the password.

 

The default static IP for the modem was 10.1.10.1 which conflicts with our subnet so I changed the IP of the modem to 10.192.10.1. I can still access it on this address but cusadmin/highspeed stopped working a few days ago which broke my script. This isn't a typo or something like that.

 

Right now our internet is down again and it really would have been nice to have access to the modem to check the signals. I'm having to post this while tethered to my phone. I do a lot of that these days.

View solution in original post

0 Kudos
Highlighted
Occasional Visitor

Re: cusadmin not a valid username on our DPC3939B anymore

The script is running on the same machine (on the LAN) that it's been running on for a few weeks. Nothing has changed... at all.

View solution in original post

0 Kudos
Highlighted
Occasional Visitor

Re: cusadmin not a valid username on our DPC3939B anymore

Okay so I took a laptop into the server room and plugged directly into the ComCast modem and got an IP from the modem (we have a block of IPs and normally use our own router) and still couldn't log in (Invalid User) and still didn't have internet access. So I power cycled the modem and now when I am plugged directly into the ComCast modem I get internet and now I can loggin with cusadmin/highspeed again. But our block of statics still doesn't have internet access. It goes out about 4 hops and then dies. So the traffic leaves our office and terminates on ComCast's network. Of course comcast tech support tells me it's our router. Funny I am able to ping 4 hops out yet it's some how our network. So we will be down until Friday afternoon until a tech comes out just to say, oh yeah, it's a routing problem on our end. Great bisiness service.

 

BTW, our traffic ends at 68.86.171.253. But when I don't use our statics and just let the modem give out an IP it works fine (Read my next reply. It only works when plugged into the CG when running IPv6). This IS NOT our problem.

View solution in original post

0 Kudos
Highlighted
Occasional Visitor

Re: cusadmin not a valid username on our DPC3939B anymore

Okay.. A little more detail. When I plug directly into the CG it works but only over IPv6. If I turn off IPv6 (On my NIC) then traffic dies 4 hops out. This is very clearly a routing problem on ComCast's end and nothing to do without our router. I suspect we will be down for a while before this escalates far enough up the chain.

View solution in original post

0 Kudos
Highlighted
Visitor

Re: cusadmin not a valid username on our DPC3939B anymore

Noel,

 

Hey bud! Have you been able to resolve this ? 

 

I hope so, let us know.

 

Thanks,

 

Joe

Internet Exploder - Version 20.15 - Xfinity & Beyond! - Comcast 4 Life

View solution in original post

0 Kudos
7 REPLIES 7
Highlighted
Trusted Forum Contributor

Re: cusadmin not a valid username on our DPC3939B anymore

Hello Noel and welcome,

 

Comcast does not change their default customer login credentials, however, customers frquently do. It is always necessary to use a computer with an Ethernet cable plugged directly into any of the rear Lanports 1-4. The standard browser address 10.1.10.1n unless reprogrammed by the customer,  and username=cusadmin, password=highspeed.

 

 

If your Comcast Gateway (CG) does not use a staticIP or has no port forwarding, triggering, etc. setup configuration parameters, i.e. just bland DHCP server implementation, then you can depress the little black reset button on the rear of the CG for 15 seconds minimum, and your factory defaults will be restored, including your default login credentials.

 

Hope this helps you out. 

View solution in original post

Highlighted
Visitor

Re: cusadmin not a valid username on our DPC3939B anymore

If you are trying to access it from the Web - or outside of the LAN - you will get that message.

 

 

I am not sure how your script was running previously or how you are testing it - but that might not be the reason your script stopped working.

 

If you are checking from the outside - it will tell you that the "cusadmin" is not valid.

 

Let me know if this helps at all bud... good luck.

 

-Joe

Internet Exploder - Version 20.15 - Xfinity & Beyond! - Comcast 4 Life

View solution in original post

0 Kudos
Highlighted
Occasional Visitor

Re: cusadmin not a valid username on our DPC3939B anymore

I wrote a script that programatically accesses the modem and logs the stats into an RRD graph. It's obvious I know these basic sugestions that are being given. I am the only one with access to the modem so I'm the only one that would change the password and I have not changed the password. We have been fighting with bad service for about a month now so I am litterally checking my RRD graphs every few hours. My script didn't forget our password out of the blue or change the password.

 

The default static IP for the modem was 10.1.10.1 which conflicts with our subnet so I changed the IP of the modem to 10.192.10.1. I can still access it on this address but cusadmin/highspeed stopped working a few days ago which broke my script. This isn't a typo or something like that.

 

Right now our internet is down again and it really would have been nice to have access to the modem to check the signals. I'm having to post this while tethered to my phone. I do a lot of that these days.

View solution in original post

0 Kudos
Highlighted
Occasional Visitor

Re: cusadmin not a valid username on our DPC3939B anymore

The script is running on the same machine (on the LAN) that it's been running on for a few weeks. Nothing has changed... at all.

View solution in original post

0 Kudos
Highlighted
Occasional Visitor

Re: cusadmin not a valid username on our DPC3939B anymore

Okay so I took a laptop into the server room and plugged directly into the ComCast modem and got an IP from the modem (we have a block of IPs and normally use our own router) and still couldn't log in (Invalid User) and still didn't have internet access. So I power cycled the modem and now when I am plugged directly into the ComCast modem I get internet and now I can loggin with cusadmin/highspeed again. But our block of statics still doesn't have internet access. It goes out about 4 hops and then dies. So the traffic leaves our office and terminates on ComCast's network. Of course comcast tech support tells me it's our router. Funny I am able to ping 4 hops out yet it's some how our network. So we will be down until Friday afternoon until a tech comes out just to say, oh yeah, it's a routing problem on our end. Great bisiness service.

 

BTW, our traffic ends at 68.86.171.253. But when I don't use our statics and just let the modem give out an IP it works fine (Read my next reply. It only works when plugged into the CG when running IPv6). This IS NOT our problem.

View solution in original post

0 Kudos
Highlighted
Occasional Visitor

Re: cusadmin not a valid username on our DPC3939B anymore

Okay.. A little more detail. When I plug directly into the CG it works but only over IPv6. If I turn off IPv6 (On my NIC) then traffic dies 4 hops out. This is very clearly a routing problem on ComCast's end and nothing to do without our router. I suspect we will be down for a while before this escalates far enough up the chain.

View solution in original post

0 Kudos
Highlighted
Visitor

Re: cusadmin not a valid username on our DPC3939B anymore

Noel,

 

Hey bud! Have you been able to resolve this ? 

 

I hope so, let us know.

 

Thanks,

 

Joe

Internet Exploder - Version 20.15 - Xfinity & Beyond! - Comcast 4 Life

View solution in original post

0 Kudos