Skip to content
depmatt's profile

Visitor

 • 

6 Messages

Tue, May 26, 2020 11:00 AM

Softphone app on Mac loses microphone connect after a while

On my mac running MacOS Mojave 10.14.6 when I start the softphone application up everything works fine. After a while clients are unable to hear me and when I go to check the settings in the application it doesn't pick up my mic anymore. The thing is I only have the one mic in and it's selected as my default in my mac settings. Now while softphone can't read the mic my system still can see me speak as well as other applications like google meet. The only solution that I have been able to come up with is to drag the application to the trash and redownload. It fixes the problem temporarily but it will lose the mic again. Any thoughts or feedback would be helpful as this is frustrating. 

Responses

Official Employee

 • 

398 Messages

9 months ago

Oh wow, I would imagine that would be really annoying to deal with! Is there anything precedes or occurs after the mic suddenly being lost? Is there any particular timeframe where it seems to occur? Is it happening on all calls or just some? We want to help get this figured out for you!

Visitor

 • 

6 Messages

9 months ago

It seems to be random honestly. It will start off fine then when once on the phone the mic will stop picking up my voice and clients can't hear me anymore. Trying to close the app and restart it does not help. Nor does unplugging the mic and back in again. Checking my mac settings as I said the microphone works fine still in the audio/mic settings even though it does not in the softphone app. The only consistent thing I can do to replicate it is just using the application it seems.

Official Employee

 • 

135 Messages

9 months ago

I'm so sorry for the inconvenience this has caused. My wife's business relies on phone service so I know this has been frustrating. Have you tried deleting and re opening the app by chance?

Visitor

 • 

6 Messages

9 months ago

I have tried that and that is the only kind of solution so far, but the mic will still cut out eventually again. It's not a permanent fix.

Official Employee

 • 

348 Messages

9 months ago

Thank you so much and have you looked at the manufacturing book for the softphone to try any troubleshooting steps through there? 

Visitor

 • 

6 Messages

9 months ago

Is there a link for this somewhere? The troubleshooting in the application itself it's very helpful. And I don't see any links for a guide or manual in the application or in my account here.

Visitor

 • 

6 Messages

9 months ago

Thanks for the links. Unfortunately, I am not using a phone as I said I am using the Softphone Application on my Mac. And I wish I currently had another mic to try but I do not. But as my Mac, Google meet, and other programs that can read my mic work I do not believe that is the issue. I also download whatever is the latest version on the website in my account. 

softphone.png

Official Employee

 • 

398 Messages

9 months ago

This link would have various reference guides for the particular phone system models: Business VoiceEdge QRGs

 

There is also a page with a bunch of training and support that's a good one to bookmark: VoiceEdge Training and Support

 

Have you attempted to try a different microphone by any chance? Was there any updates to any of the programs lately? 

Official Employee

 • 

255 Messages

9 months ago

Are you experiencing any other issues with an application, or device while on the internet? The best thing we can do is make sure your internet connection is working ideally. 

Visitor

 • 

6 Messages

9 months ago

Unfortunately no. My other applciations work fine when utilizing my microphone and my internet is working fine. The only consistent issue I have found is with the application. I cannot continue to un-install and re-install every/every other day.  

Official Employee

 • 

398 Messages

9 months ago

I totally agree, that's obnoxious to have to continue to uninstall and reinstall the app! I appreciate all your patience with us reviewing this so far, the next step will be for us to check the account itself. Can you please click on my handle (Comcast_Gina) and send a private message with your name, the business name, the complete service address (including city, state, ZIP, suite number, etc), and the phone or account number? That will allow us to verify and access the account.