Skip to content
Royal's profile



1 Message

Wed, Dec 20, 2017 3:00 PM

NO DNS edit and Office365 printer scan-to-email broken

I am putting this message out there in the hopeful attempt that someone from Comcast Cloud Solutions support with some knowledge and power can resolve this issue.


We migrated to Office365 from Comcast hosted email back in September 2017.  Migration was mildly painful but not as bad as the horror stories that I have read on these forum (no lost emails or contacts), emails were successfully transfered over for all our email accounts, we had minor issues with multiple users on the same laptop not working with the migration assistant software but calls to migration support at (855) 867-5010 got this resolved and new passwords added.


The main PROBLEM i am having is our network printers sending emails for scan-to-email functions, we have multiple HP and Ricoh printers that all have a scan-to-email feature that has worked wonderfully for years.   Since the migration, it's been a pain to get these to talk to the new Office365 setup, I got it to work using the old server address as a stop-gap measure BUT a few days ago this stopped working.


I have followed the insuructions that I found online (via many forums Microsoft, Ricoh, HP etc...) and even that Comcast have given out via

And it still doesn't work !!!  Option 1 is a NO-GO and Option 2 was working partly with all emails sent from the printer getting classified as spam/junk.


As a possible fix to Option 2, I wanted to edit my DNS to change the SPF record to include our public IP address, no biggie, easy... piece of cake...


Then the BIG SUCKER PUNCH...   I now DO NOThave access or the ability to edit my own DNS!!!   Ever since signing up for Comcast business class internet we have kept our DNS at comcast/hostways/siteprotect, and shortly after the Office365 migration I was able to with support's help find the new way to edit my DNS going from the old "business class" portal method to the new "cloud solutions" portal method.  That is until TODAY when I wanted to go and update the SPF info within my DNS to see if I could get the option 2 direct send solution linked above to Office365 to work by adding the public IP address of our network to my SPF DNS record.   BAM! NO CAN DO!!!


I have spent over 3hrs today on the phone to Comcast Busines, Cloud Migration and Hostways support and it's like everyone points the finger back to someone else, it's like the proverbial hot potato that NO-ONE wants to handle!  I have spoken to so many people today and in the past few months and even got the trouble ticket kicked to a supervisor today and still NOTHING.


I'm a pretty good operator and can work through a problem to find a solution BUT it's been a really tough day speaking to 4 comcast reps, 2 hostways/siteprotect reps, and even a conference calls between Hostways & Comcast and the finger firmly gets pointed back to Cloud Migration department who then point the troube back to Hostways/siteprotect.


Can someone reach out to me at Tier 3 support so I can get this resolved, I have multiple trouble ticket opened going back to october when I first reported this issue but even the linked solution was not provided until today. 


It's incredibly frustrating to have these wonderful scanner/printer devices that are now dead with no ability to send scan-to-emails.





1.1K Messages

4 y ago

Hi Royal and welcome to business forums.


I would like to assist with your printer and DNS issues. Please private message me your full name, the full service address and the phone number associated with your account.