Skip to content
bslusarek's profile

New Contributor

 • 

12 Messages

Mon, Feb 9, 2015 10:00 AM

Unable to modify or add users to distribution groups using Outlook 2010/2013

I'm unable to add or remove users from a distrubtion group in our GAL anymore since the Exchange server migration. Also all emails to prevous groups fail and bounce back. I tried deleting them and recreate them in the Bussiness Portal but I'm unable to add any users to any group now. 

 

"Outlook is trying to retrieve data from the Microsoft Exchage server W14CLBCH2.W14D.comcast.net."

 

Outlook will remain unrespoinsive until I force close it.

 

Others are having the same issue. It's nothing but problem after problem with Comcast's email servers.

http://forums.businesshelp.comcast.com/t5/Microsoft-Communication-Services/Cannot-edit-global-address-book-DL-s/m-p/22518#U22518

 

New Contributor

 • 

12 Messages

8 y ago

Is anyone else having this same problem?

Visitor

 • 

6 Messages

8 y ago


Yes, not having any luck, tried to different verison of outlook client new and old and tried webmail but not option to add under addressbook once open.

Visitor

 • 

6 Messages

8 y ago

So from the link above, seems they are aware of the problem. Only work around I could figure out was tyo either add a alias or forwarder. This only works for one person though. So in forwarding, you can create a distrubution with something like Gmail and then add peoples emails there. Then forward to that gmail account.

Visitor

 • 

6 Messages

8 y ago

Ah just tried Gmail forwarding, and they only allow one email forwarding address. Nevermind.

Administrator

 • 

1.5K Messages

8 y ago

Post moved for better visibility.