Skip to content
mikehanley's profile

New Contributor

 • 

7 Messages

Sun, Aug 2, 2020 4:00 PM

Comcast Static IPv6 Setup on UniFi Security Gateway 4P

Hello,

I am having issues setting up my static IPv6 Address from my Comcast Cable Modem. If I bypass the USG and connect directly to the Comcast Cable Modem, IPv6 works correctly. I also have my static IPv4 address working correctly on the USG.

 

I reviewed the following Instructions:

 

Using the Unifi Controller UI, I am stumped on the following values

 

IPv6 WAN (via Internet -> WAN Networks)

  • IPv6 Connection Types: Static IP
  • IPv6 Address: what value do I use here?
  • Prefix Length: 64
  • Router: what value do I use here?

IPv6 LAN (via Local Networks)

  • IPv6 Interface Type: Static
  • IPv6 Gateway Subnet: what value do I use here?
  • IPv6 RA Priority: Enabled

I feeling like I must be missing something very basic. Any help would be very much appreciated.

Responses

Official Employee

 • 

260 Messages

8 m ago

Hello, how are you? I hope overall your day is going well. I am sorry you are having trouble with your IPv6 address. Let me take a closer look at your modem and your IP address. Are you able to send a private message when you have a chance? If you could include your name, service address, and account number (or phone number) I can help you in greater detail.

Contributor

 • 

13 Messages

8 m ago

Unfortunately IPv6 on Comcast Business is not truely static. They assign your IPv6 addresses utilizing prefix deligation (PD). In my experience the address range is tied to the modem so if your device is ever swapped you will get a new range unlike IPv4 which can be transfered from device to device since they use RIP for routing IPv4.

 

Not sure what modem Comcast supplied you but assuming your IPv6 PD is working correctly on the modem you can request the address on your USG with PD. I'm using a Ubiquiti EdgeRouter, IPv6 PD works by requesting a /59 from the modem with rapid-commit disabled and requesting a prefix only. It should be similar on the USG.

New Contributor

 • 

7 Messages

8 m ago

Thank you, I set the WAN IPv6 side to DHCPv6 and set the Prefix Delegation Side to 56 (I also tried 64 as I read a lot of pots that the the full 56 wasn't making its through). And I ran the following two commands (eht2 is the interfafe that has the WAN side):

 

set interfaces ethernet eth2 dhcpv6-pd prefix-only

set interfaces ethernet eth2 dhcpv6-pd rapid-commit disable

 

I get an IPv6 address on eth2 and I am able to use ping6 on the USG and get responses successfully.

 

On the LAN side I set it to Prefix Delegation. 

 

On a host connected to the LAN side, I get an IPv6 address but the gateway is always coming back as a link-local address and I get a General Failure when I try to force an IPv6 ping.

 

Thanks again.

Official Employee

 • 

518 Messages

8 m ago

Thanks so much for taking the time to reach out to us regarding your IPV6 concerns. I very much appreciate your patience and greatly apologize for the delay in our response. I know how important the services are to your business and we want to do all that we can to assist. I would love to confirm the static Ipv6 block for you and ensure that all is working correctly on our side of things including the modem settings. Can you please reach out through private message with your first and last name, business service address and account number or phone number? 

New Contributor

 • 

7 Messages

8 m ago

Hello, I am trying to respond to the private message I was sent but it says I have reached the 4 message limit. 

Official Employee

 • 

401 Messages

8 m ago

Oh no! Please try clearing the cache and cookies and trying once more. If that doesn't work, please let us know! 

New Contributor

 • 

7 Messages

8 m ago

Contributor

 • 

17 Messages

8 m ago

Mike, did you ever get a response/fix?

 

As you can see that previous thread is closed/locked... I have been in the same boat (broken IPv6 DHCPv6-PD) for almost a year with 0 traction or resolution.

New Contributor

 • 

7 Messages

8 m ago

Comcast told me that there is nothing they can do.

Pretty disappointing given the cost of the service.

I tried a Cisco ASA appliance as well and I get the same issue so it is clearly a limitation (bug) on the Comcast cable modem.

New problem solver

 • 

63 Messages

8 m ago

The Comcast IPv6 deployment state for its business customers is pretty sad given for them trying to be an IPv6 leader a few years ago. 

 

https://www.nexttv.com/news/comcast-our-broadband-network-ipv6-ready-382684

Official Employee

 • 

348 Messages

8 m ago

Good morning, thank you so much for taking the time to provide your feedback about your concerns to the Digital Care team here through the forums. I am so sorry to see that we have made you feel this way as this is not what we strive for and we are sorry for the delayed response. I know how frustrating this can be when there is no resolution that you are happy with and we can look into this for you. Can you please send us a private message with your name, the full address, and the phone/account number? 

New Contributor

 • 

7 Messages

7 m ago

Has anyone been able to get Comcast Business Static IPv6 working? It just seems like it is fundamentally broken and poorly documented and supported.

New Contributor

 • 

7 Messages

3 m ago

Yes Mike - I have it working for the last 5+ years (3+ using a UniFi USG), but using the older CG3000DCR modem/router. I have the comcast modem set as a bridge only and set it to assign all ipv6 addressing for the complete network, but the USG. Unlike others I do not have the USG set for Prefix Delegation, but have it set to 'Static' using the prefix supplied by comcast and ::1. I did this set-up based on one I had previous with a netgear firewall that worked using a century link and then this comcast modem. My gateway is a local link fe80 address, which is the comcast modem - the USG acts like it is not even there going out, which it should. Coming in I have the USG block all IPv6 but my servers and only on ports needed. On the USG I also have the subnet as /64 in the static settings - this seems to work best for my setup. I have seen others with other settings, but this has worked for years, so I do not touch it.

Maybe this can help someone else.