Skip to content
NetDog's profile

New Contributor

 • 

4 Messages

Tuesday, February 23rd, 2016 12:00 PM

Cisco IOS Issues with DHCP PD??

Anyone else having issues with DHCPv6 on the Cisco IOS after about 3 months?  It will drop v6 and I have to do a {clear ipv6 dhcp client GigabitEthernet0/0} to get it back..

 

I wrote a script to check for v6 down on my linux box and fix it when it is gone..  Example below:

 

NetDogRT01#sh ipv6 int br
GigabitEthernet0/0         [up/up]
    FE80::A:B:C:D:E:F
    2001:55C:::A:B:C:D:E:F
GigabitEthernet0/1         [up/up]
    FE80:::A:B:C:D:E:F

NetDogRT01#clear ipv6 dhcp client GigabitEthernet0/0

NetDogRT01#sh ipv6 int br
GigabitEthernet0/0         [up/up]
    FE80::A:B:C:D:E:F
    2001:55C::A:B:C:D:E:F
GigabitEthernet0/1         [up/up]
    FE80::A:B:C:D:E:F
    2001:55C::1

 

 

Accepted Solution

Problem solver

 • 

90 Messages

8 years ago

I haven't tried other routers but I am tring a EdgeMAX router now..

 

no logs..  Version 15.1(4)M7..

 

ipv6 unicast-routing
ipv6 cef
interface GigabitEthernet0/0
 ipv6 address dhcp
 ipv6 enable
 ipv6 nd dad attempts 0
 ipv6 nd autoconfig default-route
 ipv6 dhcp client pd prefix-from-Comcast
interface GigabitEthernet0/1
 ipv6 address prefix-from-Comcast ::1/64
 ipv6 enable
ipv6 access-list ipv6_inbound
 evaluate ipv6_ref-inbound
 ***Removed some ACL's ***
 sequence 100000 deny ipv6 any any log
ipv6 access-list ipv6_outbound
 permit ipv6 2601::/28 any reflect ipv6_ref-inbound
 permit ipv6 {Static Test Block}::/56 any reflect ipv6_ref-inbound

Gold Problem solver

 • 

610 Messages

8 years ago

which IOS version, which device? can you post parts of your running-config, or logs? i recently acquired a leftover 1921 from my work, i will be configuring it soon & will report if I see any issues over time.

 

I will say that across numerous consumer/small business routers I've used, I will periodically (every few months or so) have to clear the DHCPv6 "DUID" on them because I will lose routable v6 access (on some of them such as Ubiquitis where I have packet tracing abilities, I will do a trace on the WAN interfface, and will see outbound v6 packets with correct source/destination go out, but get no replies back. Clearing the DUID always results in a new prefix being obtained, fixing the issue)

 

To be honest, since this issue happens across so many devices, I figured it was a misconfiguration on Comcast's end.... could very well be wrong tho.

Problem solver

 • 

326 Messages

8 years ago

I have no problems on a Cisco 2811 running c2800nm-advipservicesk9-mz.124-blahblahblah

 

I think you need to channel Scottie:

 

"the more they overthink the plumbing the easier it is to stop up the drain"

 

Here's my config:

 

interface fastethernet0/0

description to comcase

ip address 50.198.16.19 255.255.255.guesswhat

no ip redirects

no ip unreachables

ip nbar protocol-discovery

ip nat outside

ip virtual-reassembly

duplex auto

speed auto

ipv6 address autoconfig

ipc6 enable

ipv6 dhcp client pd dhcp-prefix rapid-commit

random-detect dscp-based

no cdp enable

crypto map nolan

 

interface fastethernet0/1

description lan interface

ip address 172.16.1.1 255.255.255.0

ip nat inside

ip virtual-reassembly

duplex auto

speed auto

ipv6 address 2601:1c2:1:44f0::/64 eui-64

ipv6 enable

 

ipv6 route ::/0  Fastethernet0/0 FE80::ABD:43FF:FE9a:E0AF

 

New Member

 • 

1 Message

7 years ago

I think I was having the equivalent problem a couple of days ago.  In my case, I had been advised by Tier 1 support that I needed to upgrade to their newer combo WiFi modem to get IPv6 functionality which seemed like it was already in the older SMC modem.  I didn't fight the modem swap as long as it didn't cost me anything.  Once I got the new modem, I started seeing IPv6 addresses registered in the modem, and I was able to configure my C2900 to use it.

 

I saw the problem described above, if I (or Comcast) happened to reboot the modem device after the C2900 happened to have gotten prefix values from the modem, the modem wouldn't remember (or know) that it should route packets to the prefix I'd previously been allocated.  I had this problem since my router's LAN port was actually connected to a switch port on a VLAN devoted to the Comcast Modem's LAN segment.  The problem here is that when the modem was rebooted, the switch just saw that port go offline and the other ports on the VLAN didn't notice the downward and subsequent upward link state change on the modem's LAN.  The solution is to merely wire the router's LAN port directly into one of the modem's LAN ports and when the modem reboots, the router sees the link state down and when it comes back up, it will issue new dhcp6 requests to reacquire the same prefixes and packet routing will flow naturally.  This wasn't necessary before IPv6 came into the picture since the modem didn't actually know or care (ahead of time) that any of the static addresses were on the LAN.