Skip to content
Kurtm's profile



2 Messages

Tue, Dec 9, 2014 2:00 PM

1-1 NAT Fail (DPC3939B)

I just switched to Comcast Business with 5 Usable static IP’s

I tried to use 1:1 NAT, but receive an error, “Message: The Private IP has been used!”

I cannot map my static IP’s to anything...


Anyone else have this issue?


My Gateway info is below


Model: DPC3939B
Vendor: Cisco
Hardware Revision: 1.0




1.9K Messages

6 y ago

HI Kurtm.  The error message provided in the post usually happens on a duplicate assignment with port forwarding.  Currently there are no 1 to 1 NAT rules active on the device.  If you could post a bit more info on the situation one of our Community Members could possibly assist.  Only include the last octet of the IP addresses involved for security purposes.


Thank You



20 Messages

6 y ago

It sounds like you may not be using your ip addresses correctly either. With our comcast block of 5 ips we did this. (Obviously 172.16.0.x is not our ip but you get the idea) comcast modem gateway
Block of ips -

Cisco router directly connected to the modem statically set to
IP address. (first usable IP address)
Subnet mask

Linux spam filter directly connected to the modem statically set to
IP address (second usable static IP address)

Using your ip addresses this way eliminates the need for 1 to 1 nat and eases the load on the modem.

Tip: If you setup a device using the modem network the traffic will go out on the gateway device giving you a 6th IP address.
Linksys wireless router
IP address
Subnet mask
This will have a public IP address of and in this case if I wanted to enable outside traffic to access my wireless router I can do a 1 to 1 nat.