Skip to content
telldrak's profile

New Contributor

 • 

2 Messages

Tue, May 17, 2016 11:00 PM

Cannot log into businessclass.comcast.net - Terms and Conditions "stuck"

This has been ongoing for over a month now. I can't get into my business class account because the system is broken and doesn't register that I've agreed to terms of service.

https://businessclass.comcast.net/Secure/MyAccount/UserTermsAndConditions/

I've even looked at the network activity for this page to ensure that the page sends out a response to the server, and I'm finding javascript errors and insecure content on the page.

 

This issue persists, no matter which browser I use.

Accepted Solution

Official Employee

 • 

869 Messages

6 years ago

Hello Randallflagg, 

 

Thank you for the follow up. I'm glad to hear you're now able to login. 

Accepted Solution

New Member

 • 

1 Message

6 years ago

What is the Fix for this?  I get the Comcast Business spinning circle once I click on the checkbox and Continue from the Terms and Conditions page.  Tried from different PC and differnt networks with same issue.

 

Please advise.  I need to logon to get my static IPs that are assigned to my router\gateway.

Accepted Solution

Visitor

 • 

3 Messages

6 years ago

An update since my last post.  Apparently the issue with the infinitely spinning Comcast logo is fixed, and now the page actually redirects to the "ReturnUrl" that was returned from the AJAX call.   One thing to note, it didn't even display the Terms and Conditions page this time around, it just went straight to the error page.

 

"ReturnUrl":"/ErrorPage?ec=500"

 

So now every time I try to log into my account I get redirected and stuck at the following URL.

 

https://businessclass.comcast.net/ErrorPage?ec=500

Any others seeing the same thing?

 

Accepted Solution

Gold Problem solver

 • 

575 Messages

5 years ago

Hello suncarems and welcome to forums,

 

I apologize for my delayed response. I have refreshed your account profile to gain better access to your account. Please test your login and let me know if the issue persists.

 

Thank You

New Member

 • 

2 Messages

7 years ago

Same issue, I can't login to my account with any browser due to "terms" best part is that my payment on file has expired and now I am forced to sit on the phone...

New Member

 • 

2 Messages

6 years ago

Resolving this issue took 2 calls, first call the support person claimed they could log in without issue, clear cache and try again (wasn't in front of my computer).  Obviously this didn't work, the second call which lasted an hour had the call escalated to tier 2 while I was on the phone and they were able to resolve it.

 

Not sure it will help but you can have them reference what they did in ticket CR597022302.

 

Funny I got an email back a few hours later from another tier 2 syaing they couldn't replicate the issue (cause it was now fixed), oops! I guess they should have cancelled the escalation.

 

Official Employee

 • 

869 Messages

6 years ago

Hello telldrak,

 

Are you able to login now? 

Official Employee

 • 

869 Messages

6 years ago

Hello ErichB,

 

I was having issues pulling you account information to refresh your portal account. Can you please send me a private message with you account number so I can try and refresh your portal and get you Static info? 

 

Thank you 

Official Employee

 • 

869 Messages

6 years ago

Hello ErichB,

 

I was having issues pulling you account information to refresh your portal account. Can you please send me a private message with you account number so I can try and refresh your portal and get you Static info? 

 

Thank you 

Visitor

 • 

3 Messages

6 years ago

I'm having the same issue, I've tried Chrome on Windows, Chrome on Mac, Safari, MS Edge, same issue.  I just transferred service and need to log in to link my accounts for billing but I'm getting stuck on this Terms of Service page.  Is there any way around this without sitting on the phone for support - I'm moving and frankly don't have the time right now to do that.

 

Thanks!

Clint

Official Employee

 • 

869 Messages

6 years ago

Sorry for the delay clintkolodziej,

 

You tried all the preliminary steps already. The next step would be for us to reset the password and retry. Can you sent me a private message with your account number, username in question, and preferred email so we can try and push it through? 

 

Thank you 

Visitor

 • 

3 Messages

6 years ago

Jacob,


I sent a private message.  I also debugged what appears to be the issue.  I included it in the private message, but wanted to also post it to the forum so others can check if they are seeing the same symptoms that I am:

 

The issue is on the following page:

 

 

https://businessclass.comcast.net/Secure/MyAccount/UserTermsAndConditions/

 

 

When the button is pressed to accept the terms it does an AJAX POST to the following URL:

 

 

https://businessclass.comcast.net/api/bcp/TermsAndConditions/AcceptTermsAndConditions?isAccept=true 

 

 

That URL is responding with a HTTP 200 (success) response code, but the data being returned shows IsSuccess false, which is preventing the caller page from continuing as expected:

 

 

{"IsSuccess":false,"Message":null,"WifiResponse":null,"Data":{"TermDescription":null,"IsShowPrintButton":false,"ReturnUrl":"/ErrorPage?ec=500","TosSiteCoreContent":null}}


The Javascript on the caller page looks like this, as you can see it will only continue if the IsSuccess value that is returned is True, which is why I'm seeing just a stuck spinning logo:

 

 

 

            self.function () {
                $(document).trigger("c-page-spinner-open");
                var selfCopy = self;
                var reqObj = {
                    "isAccept": self.isTOSChecked
                };
                var params = {
                    type: 'POST',
                    url: '/api/bcp/TermsAndConditions/AcceptTermsAndConditions?isAccept=' + self.isTOSChecked()
                    //url: '/api/bcp/TermsAndConditions/AcceptTermsAndConditions',
                    //requestObject: JSON.stringify(reqObj)
                };

                self.ProcessAjaxRequest(params, function (jsonData) {

                    if (jsonData && jsonData.IsSuccess) {
                        //Need to update
                        location.href = jsonData.Data.ReturnUrl;
                    }
                });
            };

 

 

 

New Member

 • 

1 Message

6 years ago

Also been having the same problem for a few months. Makes it a bit difficult to set up autobill pay. Would really appreciate it if someone from comcast would help me address the issue without me calling and spending all afternoon on the phone.

 

H

New Member

 • 

2 Messages

6 years ago

Same issue here.  Can somebody fix my account?

Official Employee

 • 

869 Messages

6 years ago

Hello demonfox, 

 

It should be cleared now, if you're still having issues getting past that page please let us know.