Skip to content
sgarrabrant's profile

New Member

 • 

2 Messages

Tue, Oct 30, 2018 2:00 PM

xfinity wifi hotspot access no longer working

I am a comcast business customer.  In the past, I have used the same login credentials to access the xfinity wifi hotspots as I do for my comcast business account.  When last I traveled (early September) things were working fine.  This week, I repeatedly get a "username not found" error, and it tells me that I need to configure my xfinity account from my business account.  I contacted the online "chat" help from the comcast business site, and they told me they could not correct it and would escalate the issue.  What I received was an automated email with links on how to configure a hotspot.  

 

Can someone please tell me who to contact or how to correct this?  needing it to work when next I travel.

Thanks!

 

Responses

Official Employee

 • 

225 Messages

2 y ago

Thanks for reaching out to us on our Comcast Business Support Forums, sgarrabrant. I can take a look at your username and see what's going on with the Xfinity Hotspot access. Could you send me a private message with your full name, the phone number listed on the account and, the username you use to log in with?

New Member

 • 

2 Messages

2 y ago

Sure, if you will tell me how to private message.  I only see an option to reply, nowhere to make it private.  

Official Employee

 • 

240 Messages

2 y ago

Here is a link on how to send a private message. Please let me know if this helps. https://forums.xfinity.com/t5/help/faqpage/faq-category-id/pm#pm

New Contributor

 • 

5 Messages

2 y ago

Seems like this issue is reported all over this thread.  Noone mentions the cause.  I'm betting that XFINITY WiFi only recognizes consumer Xfinity accounts and somehow Comcast Business/Teleworker accounts no longer are authenticated correctly without some manual intervention by a "Comcast Employee".  Is this why we all have to privately message someone for every one of these reports?

 

What's the fix so people don't have to message or call Technical Support for help?

Official Employee

 • 

56 Messages

2 y ago

Thanks for reaching out to us, sorry you're having this issue. No, there hasn't been a change on how to gain or who has access. We request you private message us because typically it's something unique to that individual that is causing the issue. It helps us to be able to identify the issue and get it solved. Let's take a closer look at what's going on with your access. Please send a private message with your name along with your account number to proceed. 

New Member

 • 

1 Message

1 y ago

I have same problem. My Comcast Business login is not recognized in "xfinitywifi" or "XFINITY" networks. I wasted countless hours with Comcast support trying to reslove the issue. But, still no solution. If I understand there are thousands of businesses utilizing Comcast Business services and comcast support I been dealing with, sounds like have little knowladge of the issue.

Official Employee

 • 

518 Messages

1 y ago

Thanks so much for taking the time to reach out to us regarding your hotspot issues. I very much appreciate your patience and greatly apologize for the delay in our response. I know how important the services are to your business and we want to do all that we can to assist. I know how frustrating any connection issue can be and I am sorry to hear that you are having issues logging into our hotspots Can you please reach out through private message with your first and last name, business service address and account number or phone number?