Skip to content
cbeuser's profile

New Contributor

 • 

2 Messages

Wed, Jan 27, 2021 1:00 PM

Softphone Not Ringing on Incoming Calls

We are using the latest version of the Comcast Business Voice Edge Desktop app. It works fine for most people we have tried it with but I have two people where nothing happens when an incoming phone call comes in. It simply does not ring. I have verified do no disturb is not on. I have tried uninstall and reinstalling the app. Rebooting the computer. I verified there is a firewall rule for the app. It works just fine for most people yet simple does not work for a select few. Both users were on different ISPs at home (Comcast for one and centurylink for the other). These users can make out going calls and use all of the other features of the app yet when a phone call to their line comes it nothing happens on their computer.

 

Any suggestions?

New Contributor

 • 

2 Messages

10 m ago

Any suggestions comcast?

Official Employee

 • 

43 Messages

10 m ago

Hello and Happy Wednesday! I hope you’re having a great start to the week! I also appreciate you taking a moment out of your day to reach out to us on our Community Forums and apologize greatly for the delay in response time! You’ve reached the best place and perfect person to help with virtually all of your account needs! Going forward, I'm truly sorry to hear about the out going call issues you're experiencing to the specific phone numbers in question. I know this must be frustrating and we'd like to help! So that we can take a closer look at the situation, please send us a private message by clicking my name "ComcastJosephW" then select "Send a Message" on the right side with your name and service address to get started. Thanks again for both your time and patience!