Skip to content
S

New Contributor

 • 

9 Messages

Mon, Jun 6, 2022 2:12 PM

Disconnect order still hasn't gone through

Good morning!

I recently switched from Comcast Business over to Xfinity (residential). My residential service is up and working great, however my Business account is still active, despite the disconnect order having been submitted way back on May 26th.

I called in since then and spoke to a polite gentleman who said he would expedite the disconnect order, but it still hasn't been processed today on June 6th. I'd like to get this taken care of already since my next billing cycle starts on June 12th, so I'm trying this different channel. Let me know if anyone here can help me out with this.

Official Employee

 • 

15 Messages

2 m ago

Hi there, @SpottedCat, thank you for taking the time to reach out to us through our Comcast Business forums. I am sad to hear your disconnect request has not been processed. Please rest assure you have reached the right team for assistance. To get started, please send us a direct message with your full name and service address.

Here's the detailed steps to direct message us: 

 • Click "Sign In" if necessary

 • Click the "Direct Messaging" icon (upper right corner of this page)

 • Click the "New message" (pencil and paper) icon

 • Type "Comcast Business" in the to line and select "Comcast Business" from the drop-down list

 • Type your message in the text area near the bottom of the window

 • Press Enter to send your message

 

New Contributor

 • 

7 Messages

2 m ago

Were you using your own modem? How were you able to add that modem to residential? I signed off on the disconnect order but can't activate my residential until my current modem is taken off the business account, so I can't activate it on residential. 

New Contributor

 • 

9 Messages

@Jigs2008​ I bought a new modem for residential (Arris S33) as my previous SB6183 wasn't sufficient for the tier I wanted.