Microsoft Services & Apps
Helping businesses with applications for a smarter cloud strategy
Back to Top

Outlook 2011 for Mac suddenly can't access Exchange

Suzi
New Member

Outlook 2011 for Mac suddenly can't access Exchange

As of yesterday afternoon (Jan 27, 2016), office Mac users could not use Outlook 2011 for Mac to access our Comcast Hosted Exchange server.  Similar issue with Apple Mail on MacBooks, but NOT for iPhone Mail users.  Windows users with Outlook 2010 had no problems.  Browser-based Outlook Web Access users had no problems.  

 

Affected users who can no longer use Outlook 2011 for Mac, CAN use browser-based Outlook Web Access, but this isn't a complete workaround.  Because problem appeared simultaneously on multiple office MacBook Pros (which for 18 months had been happily using Outlook 2011 with Comcast Hosted Exchange), I suspect a new configuration at the Comcast Hosted Exchange Server caused the issue.

 

While researching, I came across this Microsoft Knowledgebase article from last fall....

    https://support.microsoft.com/en-us/kb/2955530

 

...which states:  

 

"You cannot connect to a server that is running Microsoft Exchange Server from a Microsoft Outlook 2016 for Mac or Outlook for Mac 2011 client after disabling Secure Sockets Layer (SSL) on the server.

 

The connection failure occurs because Outlook for Mac uses SSL to establish communication with an Exchange server. When SSL is disabled and secure renegotiation is implemented as defined in RFC 5746, Outlook requires the server to be in Compatible mode so that the session can be renegotiated from SSL to Transport Layer Security (TLS). "

 

This affects ALL version of Outlook for Mac (2011, 365, and 2016) if the Exchange Server is configured for STRICT mode.  Instead, the Exchange Server must be configured for COMPATIBLE mode for Outlook for Mac users to keep on working.  Our assigned Comcast Hosted Exchange server (Exchange 2010) is part of server cluser "w14d".  

 

This has been reported to and is in the queue for Comcast Tier 2 support as incident CR553332118, but as of this time I don't know if anyone has yet looked at it.  To complicate things, I understand Comcast Tier 2 will have to go to MICROSOFT, who is actually running the servers for Comcast.

 

It's possible there is another cause; if the server's security certificate has been replaced so that SSL v2 and SSL v3 are no longer supported.

 

My heart is Bleeding over this POODLE of issues, and my Mac users are getting upset.  Anyone else have some insight on this issue, or how to work around it ?