IPV6
Internet Protocol version 6
Back to Top

My LAN hosts are getting the (Comcast) WAN default route instead of the gateway

StarNet
Contributor

My LAN hosts are getting the (Comcast) WAN default route instead of the gateway

We have some computers with Comcast static IP (v4) address connected directly to our modem. The modem has a link-level address of fe80::7acd:8eff:fee4:4fd6 (which it calls a LAN IPV6 address, but that is confusing because our real LAN is on the other side of a Peplink Balance 20 router).

 

We have a few Linux systems that connect both to the Comcast modem and our LAN, as well as the Peplink router mentioned above. These systems can make outgoing IPv6 connections successfully. The LAN link-level address for this router is fe80::256:caff:fe04:2820, but the problem is that all the singly-connected systems on the LAN are getting fe80::7acd:8eff:fee4:4fd6 as their default route.

 

The Peplink people are looking into this, but I thought I'd ask here as well if anyone knows how this route could be "leaking" onto our LAN?

Trusted Forum Contributor

Re: My LAN hosts are getting the (Comcast) WAN default route instead of the gateway

Hello StarNet and welcome,

 

Are any of your computer using Comcast static IP or are you running full boar DHCP?  

 

Also, what Comcast Gateway are you using?  

 

What other ISPs are connected to your Peplink Balance 20 router ?

 

Are you using any SpeedFusion across your 13 links? 

 

Look forward to hearing from you.

Forum Contributor

Re: My LAN hosts are getting the (Comcast) WAN default route instead of the gateway

By spec, link-level IPv6 addresses are "unroutable"  Meaning that any IPv6-compliant router getting a packet for a destination address on a network starting with fe80 will ignore it.

 

By spec, fe80 addresses are only used for LAN communication and for finding out the default GW.

 

Usually an IPv6 host will setup a default route entry to the fe80 address of the IPv6 router to the "outside"  If you try to ping a host with a fe80 address that isn't on your local LAN your host should issue a network unreachable and not even try sending the packet out.

 

It sounds like you have either multihomed Windows workstations or you have 2 routers on the same LAN that are advertising themselves as the default gateway.  But beyond that it's really difficult to understand how this is organized, can you provide an ASCII diagram of how things are plugged in?

StarNet
Contributor

Re: My LAN hosts are getting the (Comcast) WAN default route instead of the gateway

Something changed and now the LAN hosts have the correct default route to the gateway. So that problem is solved.

However, while I can ping external IPv6 hosts, TCP (or at least HTTP) connections are always timing out.

The people at PepLink are working on that problem right not.

Highlighted
StarNet
Contributor

Different problem now.

> Are any of your computer using Comcast static IP or are you running full boar DHCP?  

Yes, we are using only Comcast static IP address. (...for IPv4. As I understand, Comcast is not yet issuing static IPv6 blocks.) 

> Also, what Comcast Gateway are you using?

 It appears to be the SMC Networks 1.01.

> What other ISPs are connected to your Peplink Balance 20 router ?

 AT&T Business Fiber Service (new in our building).

> Are you using any SpeedFusion across your 13 links?

No. The Balance 20 doesn't support it.

StarNet
Contributor

Peplink is working on it.

I have been working with the very competent people at Peplink with this problem.

So far, we have found that the problem happerns with Peplink firmware version 6.2.1, but not 6.1.2. Clearly, it is a bug and they are working on it.

 

I have also learned that the Peplink router's IPv6 stack is working in "passthrough" mode, which means that the hosts on the LAN see the Comcast modem as the directly-connected IPv6 gateway, even though it is physically one hop away.