IPV6
Back to Top

IPv6 and the Cisco DPC3941B

SOLVED
jaybee
Visitor

IPv6 and the Cisco DPC3941B

I have a business account. I have a situation with a customer in Asia wherein I need to get this working. Can anyone confirm that this device (Cisco DPC3941B) will work/respond appropriately with v6 PD request? I can see the device itself has a /56, has taken a /64 for itself, and i can ping devices from the gateway, but cannot seem to get it to delegate. In my case I have Ubiquiti EdgeRouter, but I have tried others as well. I also tried to get it running using private IPv6 space on the interiour, but it appears I cannot get enter a static route for v6 on the device. I've seen notes on various forumns that suggest the Cisco device will not work, or needs to be on a special version. I'm looking for some confirmation one way or the other.

 

I am a network engineer by trade, and while perhpas not a v6 ninja, do know my way around an IP stack. Any insights would be appreciated.

 

Thank you

 

Jim

 

hw 1.0
DOCSIS Software Version: dpc3941b-v303r20421911-181127a-CMCST
Software Image Name: dpc3941b-v303r20421911-181127a-CMCST.p7b

Accepted Solution

Re: IPv6 and the Cisco DPC3941B

Thanks for reaching out to us on our Comcast Business Support Forums, jaybee. The Prefix for V6 should be working with that model modem. As long as the Stateful use is enabled on the IPV6 DHCP LAN, it should be working properly.

 

Can you confirm if Stateful use for IPV6 DHCP is enabled?

View solution in context
Accepted Solution

Re: IPv6 and the Cisco DPC3941B

Thank you for reaching out. Marathon session last night, I think I have it working. It involved rebooting a few things after changing configs. (That is an after hours activity) I'll be posting the config to ubiquiti later today if it is helpful to anyone else.
View solution in context
Accepted Solution

Re: IPv6 and the Cisco DPC3941B

This is the ubiquiti config that got me going. Obviously, you might want to add firewalls and otehr niceties.

 

set interfaces ethernet eth0 dhcpv6-pd pd 0 interface eth1 no-dns
set interfaces ethernet eth0 dhcpv6-pd pd 0 interface eth1 prefix-id :1
set interfaces ethernet eth0 dhcpv6-pd pd 0 interface eth1 service slaac
set interfaces ethernet eth0 dhcpv6-pd pd 0 prefix-length /59
set interfaces ethernet eth0 dhcpv6-pd prefix-only
set interfaces ethernet eth0 dhcpv6-pd rapid-commit disable

 

As it turns out, other prefix sizes did not work. The /59 was the key. The Cisco device itself is issues a /56.

View solution in context
Official Employee

Re: IPv6 and the Cisco DPC3941B

Thanks for reaching out to us on our Comcast Business Support Forums, jaybee. The Prefix for V6 should be working with that model modem. As long as the Stateful use is enabled on the IPV6 DHCP LAN, it should be working properly.

 

Can you confirm if Stateful use for IPV6 DHCP is enabled?

jaybee
Visitor

Re: IPv6 and the Cisco DPC3941B

Stateless and stateful are both enabled. Stateless does not appear to be unselectable.

 

The DHCP server has assigned itself a /64 out of the /56 the router has been assigned.

 

jim

Highlighted
Official Employee

Re: IPv6 and the Cisco DPC3941B

Thanks for verifying. I'll need to take a look at the Comcast Business Modem itself to see if the IPv6 is distributing correctly. Please, private message me your full name and phone number. I'd be more than happy to assist!

jaybee
Visitor

Re: IPv6 and the Cisco DPC3941B

Thank you for reaching out. Marathon session last night, I think I have it working. It involved rebooting a few things after changing configs. (That is an after hours activity) I'll be posting the config to ubiquiti later today if it is helpful to anyone else.
Official Employee

Re: IPv6 and the Cisco DPC3941B

That would be awesome. Thanks for sharing your issue and how you came to a solution on our forum. Also, thanks for choosing Comcast Business! We appreciate you taking the time to share your feedback and your business.

jaybee
Visitor

Re: IPv6 and the Cisco DPC3941B

This is the ubiquiti config that got me going. Obviously, you might want to add firewalls and otehr niceties.

 

set interfaces ethernet eth0 dhcpv6-pd pd 0 interface eth1 no-dns
set interfaces ethernet eth0 dhcpv6-pd pd 0 interface eth1 prefix-id :1
set interfaces ethernet eth0 dhcpv6-pd pd 0 interface eth1 service slaac
set interfaces ethernet eth0 dhcpv6-pd pd 0 prefix-length /59
set interfaces ethernet eth0 dhcpv6-pd prefix-only
set interfaces ethernet eth0 dhcpv6-pd rapid-commit disable

 

As it turns out, other prefix sizes did not work. The /59 was the key. The Cisco device itself is issues a /56.

Official Employee

Re: IPv6 and the Cisco DPC3941B

I am so glad to hear that we were able to get all of your concerns addressed and you were able to resolve the static issue. If you need anything further please reach out to us at any time.