IPV6
Internet Protocol Version 6
Male IT Specialist Holds Laptop and Discusses Work with Female Server Technician. They're Standing in Data Center, Rack Server Cabinet is Open.
Visitor

DHCPv6-PD still broken on CGA4131COM

I attempted this post before but apparently it only saved a draft with my message tags set - let's try again.

 

I'm running into the exact same issues as in other threads with a static IPv4 address and attempting DHCPv6-PD; it appears only holmosapien has gotten a real fix, and I'm hoping to piggyback off their success. 

 

I have a CGA4131COM, I'm using a static IPv4 address and receiving a DHCPv6 address on my WAN. From my router (the only device connected to the modem), I can

ping6 google.com

but from my LAN interface or any devices on my LAN, which received an IPv6 address in the delegated range, the modem drops them, as evidenced by packet sniffing the link between the modem and router (the modem sends out neighbor solicitations trying to look up the address from a range it delegated).  

0 Kudos
Reply
14 REPLIES 14
Highlighted
Visitor

Re: DHCPv6-PD still broken on CGA4131COM

Unfortunately I think I need to BUMP this thread. I have received no response to this thread or to a ticket I opened Monday morning regarding this issue. I can provide the ticket number to any followup here so as to not duplicate efforts.

 

I would really like to speak to someone to discuss my options, be it replace my modem, purchase one of my own, or explore other services.

 

Update: I've gotten a response, and will update this with the conclusion.

0 Kudos
Reply
Highlighted
Occasional Visitor

Re: DHCPv6-PD still broken on CGA4131COM

I'm interested in Comcast's reponse to this. I had the CGA4131COM (CBR-T) and had to have it replaced with the DPC-3941B (BWG) in order to get IPv6 PD working. Recently they had to roll back the firmware on my BWG to get PD to work after a firmware update broke it. I am somewhat dissatisfied with the BWG becasue it has increased my latency, likely due to it's puma chip. I would like to get the BWG replaced with the CBR-T once they fix PD, but so far I've heard there was no resolution to this.

0 Kudos
Reply
Highlighted
Official Employee

Re: DHCPv6-PD still broken on CGA4131COM

Hi! Thanks for your patience and for reaching out to Comcast for help with the modem concern. I am sorry to learn about the recent rollback of the firmware that has caused an issue with the BWG modem increasing latency. You have reached the perfect specialist to assist with this! I would like to see if we can get the modem replaced for you. In order to research this further, would you mind clicking on my handle Comcast_Gabe to send over a private message with your first/last name, address, and account number or phone number linked to the account?

0 Kudos
Reply
Highlighted
Visitor

Re: DHCPv6-PD still broken on CGA4131COM

Tier 2 is replacing my modem with the BWG as well, and I'm hoping I won't run into increased latency (a few ms is fine, more than that is not). 

 

@Comcast_Gabe can I contact you regarding the new modem if I run into the same issue?

0 Kudos
Reply
Highlighted
Occasional Visitor

Re: DHCPv6-PD still broken on CGA4131COM

Just got into a forced modem swap today and.... drumroll... IPV6 delegation is not working (get prefixes, but won't route out). Firewall is blocking attempts it seems from the log (FW.IPV6 FORWARD drop, and FW.IPV6 INPUT drop). Addresses are not identified (making these logs virtually useless), so I can't ne sure those log entries relate to the observed problem (but I have confirmed it with packet sniffer: prefixes are received, but outbound traffic from LAN devices on IPV6 disappears in a black hole, but back comes a neighbor solicitation).

 

Arrrgh. Wondering how many days or weeks it will take to get this resolved (most likely with another device).

Highlighted
Official Employee

Re: DHCPv6-PD still broken on CGA4131COM

Hi! Thank you for your patience! I am glad to hear that our Tier 2 support team is replacing the modem! Absolutely! Please feel free to reach out any time! I am here to help! 

0 Kudos
Reply
Highlighted
Occasional Visitor

Re: DHCPv6-PD still broken on CGA4131COM

Called tech support for a modem swap. Answer: Due to COVID we don't send out any techs. Told them one was just here 3 days ago. Answer: Yes we do for new installs, but nothing else. Me: The install was not finished because I have a partially working setup... No go.

 

I tried to be nice to the tech that came by telling him I'd sort out whether IPv6 was workign without having him wait another hour or 2 for me to definitely trouble shoot. Should not have done that, apparently.

 

Comcast: You are not fiing your modem problems, not even after a year.

Comcast: Your people are not informed about which modems will/not work for IPv6 so they end up installing stuff that doesn't work, even if they were told, in advance, and during the visit that IPv6 prefix delegation was a must.

Comcast: Your policies make no sense if you can do a tech involved installation, leave and then won't come back to fix problems due to COVID. What if the problem was even more serious?

0 Kudos
Reply
Highlighted
Official Employee

Re: DHCPv6-PD still broken on CGA4131COM

Hi there! I'm so sorry for the delay. During this time, we are doing our very best to make sure we respond to you as soon as possible. Thanks so much for reaching out about your concern. You've absolutely reached the right place, and are in good hands. I will own this Issue for you and ensure that I provide the best help I can today. If you send us a private note, I can gather your information, and dive into this right away. All I need is your full name, account number (follow link https://comca.st/2Z7pNLt, account number is at the top right)and address including city, state, and zip code exactly how it reflects on the bill? Thanks in advance. 

0 Kudos
Reply
Highlighted
New Contributor

Re: DHCPv6-PD still broken on CGA4131COM

I've been asking for this to get fixed for over two years with the GCA4131COM. I've had multiple techs out, had a phone conference and screen share session with folks in Philadelphia, had two escalation managers and yet nothing is solved. My tickets are all closed and I'm told we'll get it fixed. Nothing has changed. I've had my modem swapped back for a Cisco, moved, and then was told the only way to get service with the GCA4131COM device. One of the support folks admitted that the GCA4131COM needed a firmware fix, but nothing has come of that.

 

Why can't you fix this Comcast? I'm so tired of paying you thousands of dollars each year and being ignored for IPv6 support.

Highlighted
Occasional Visitor

Re: DHCPv6-PD still broken on CGA4131COM

It won't get fixed. Doesn't matter if it is incompetence or other. They don't really care, and won't until the world starts using a lot more IPv6. I switched back to the NetGear modem and all is fine.

0 Kudos
Reply
Highlighted
Visitor

Re: DHCPv6-PD still broken on CGA4131COM

Update on 10/1/2020, yes still broken (you get the delegated prefix, but the modem will not route traffic for this prefix back to your delegated router).  This is going to be a problem for all of us pretty quick as it appears Comcast intends to at some point, ONLY offer the CGA4131COM; it's already the only option for Gigabit service as well as Business Class Voice service.

 

Now, since my "contract" expired and had to renew (doubling the price of my monthly bill, without notice.)  On the phone call with "retention", Comcast basically forced me to get "double play" with Business Voice (even though I don't want it, need it, or will use it).  It was "cheaper" to get the Internet + Voice for the 200/20 package than without it (no promotion without voice).  The voice service REQUIRES the CGA4131COM.  I can't use the CGA4131COM if I want IPv6 to work.  What are they going to make me do, pay to rent TWO MODEMS because they have a broken product?

0 Kudos
Reply
Highlighted
Official Employee

Re: DHCPv6-PD still broken on CGA4131COM

Hi there! I'm so sorry for the delay. Due to increased volume, we're working to get to our valued customers as quickly as possible . Thanks so much for reaching out. You've absolutely reached the right place, and are in good hands. I will own this Issue for you and ensure that I provide the best help I can today. All I need is your full name, account number (follow link https://comca.st/2HIHmw3, account number is at the top right)and address including city, state, and zip code exactly how it reflects on the bill, and I can help you with whatever questions or concerns you may have. To protect your account, can you send me this information in a private note? 

0 Kudos
Reply
Highlighted
New Member

Re: DHCPv6-PD still broken on CGA4131COM

I am having the same issue.  I cannot get through to someone who will help.  Nobody will follow up with me from Tier 2.

 

I am paying over $300/mo for service and now that I need to implement IPv6 the modem I am required to use is not sufficient.  I am going to have to change service providers - I have spent more than a week on this and am getting nowhere.

 

Please follow up with me.  I am otherwise happy with the service until this point but not being able to use IPv6 is a deal breaker and this level of support is frustrating at best

0 Kudos
Reply
Highlighted
Official Employee

Re: DHCPv6-PD still broken on CGA4131COM

It sounds like you've done quite a lot to get this sorted out, we'd love to make sure that this is addressed. Please click on my handle (Comcast_Gina) and send a private message with your name, the business name, the complete service address (including city, state, ZIP, suite number, etc), and the phone or account number, and any pertinent details like the Tier 2 ticket number(s) so we can help. 

0 Kudos
Reply