Internet Protocol Version 6
Male IT Specialist Holds Laptop and Discusses Work with Female Server Technician. They're Standing in Data Center, Rack Server Cabinet is Open.
Occasional Visitor

DHCPv6-PD Worked With CG3000DCR Now Broken With CGA4131COM

I had 150 mbps service with a Netgear CG3000DCR and IPv6 with DHCPv6-PD worked flawlessly with my Cisco router. I decided to upgrade my service to 300 mbps and, of course, the CG3000DCR will not work with the higher speed. A technician came out to replace the CG3000DCR with a CGA4131COM for the speed upgrade. Nice that that I was able to have my phone service and Internet service on one device instead of two. The installation went smoothly and Internet and phone service is working well. Except for IPv6. After the gateway swap, IPv6 DHCPv6-PD is broken. I can do IPv6 pings and traceroutes with my Cisco router (for example Google's DNS server 2001:4860:4860::8888) with no issues. However, even with clients automatically getting IPv6 addresses, no IPv6 pings, traceroutes, or traffic will pass through or route with the CGA4131COM gateway from clients.


Since I have five static IPv4 IP's that I would have a hard time to give up, bridge mode is absolutely not an option. Having IPv6 is important.


0 Kudos
Occasional Visitor

Re: DHCPv6-PD Worked With CG3000DCR Now Broken With CGA4131COM

Just to follow this subject up so that others who are having the same issues have information. Unless one is using a Netgear CG3000DCR, IPv6 DHCP-PD does not work if you have a firewall or router behind a Technicolor CGA4131COM or CG3941B business gateway and you require static IPv4 addresses and cannot place the gateway in bridge mode. Bridge mode is the only way IPv6 DHCP-PD will work with a Technicolor gateway with a firewall or router behind it. It is disappointing that an older gateway can support IPV6 DHCP-PD with a firewall or router behind it and newer gateways cannot. Too bad Comcast cannot upgrade the firmware on the Technicolor gateways to support IPv6 DHCP-PD with a firewall or router behind it. I require my IPv4 statics, so I am abandoning IPv6 connectivity.

0 Kudos
Community Manager
Community Manager

Re: DHCPv6-PD Worked With CG3000DCR Now Broken With CGA4131COM

We do offer the DHCP IPV6 addresses to our business customers subscribed to IPV4 statics. The IPV4 static IP addresses will not work in bridge mode if you require them for use. More information can be found on our IPV6 addresses and their function through this link https://business.comcast.com/help-and-support/internet/comcast-business-internet-learn-about-ipv6/. If you have any further questions or concerns or would like us to review the routing issues further please don't hesitate to reach out to us at any time through private message with your first and last name, service address and account number or phone number? -Comcast_Michelle

0 Kudos

Re: DHCPv6-PD Worked With CG3000DCR Now Broken With CGA4131COM

ComcastBiz_Support / Comcast_Michelle -


This statement is completely unrelated to the post/request made by ITGrouch56 as well as multiple other posters/threads in your own forums (bordering on the same level of tone-deafness I’ve encountered).


The statements made by ITGrouch56 are 100% accurate. The CGA4131COM is broken at the firmware level. This escaped both your quality assurance testing as well as any limited scope testing performed before they were released to general availability.


I’ve spent the better part of the last month trying to resolve the exact same issue experienced by the individual who started this thread.


Back at the end of August, my CG3000DCR, which worked for 6+ years in a dual-stack (IPv4/IPv6) configuration behind two different Ubiquiti EdgeRouter firewalls, ceased to function and was slated for replacement.


I was provided a DPC3941B as an initial replacement, after a few days of testing/acclimation, I asked for a different device as latency/packet loss/skew is inconsistent/out-of-spec for even the internal address/static gateway assigned to the provided equipment, much less the outside world. (Google: Puma 6 chipset)


Made several emphatic requests with Tier-2/ECR to simply give me a new CG3000DCR. They were denied by local dispatch/maintenance no fewer than ~5 times, stating the device is EoL and will only cause more issues.


After nearly ~30 days of back and forth, daily emails and calls, local finally ‘caved’ and provided me a used CG3000DCR that was not only covered in white paint spatter, but scratched/gouged on all facets.


Not willing to stand in the way of progress, I accepted the obviously damaged device as the local representative stated it was the only device left, I wouldn’t be receiving another.


We brought it online and provisioned, immediately IPv6/dual-stack connectivity was restored without a single change to my equipment aside from deleting DUID, releasing/renewing the interface.


I was thrilled, sent emails to Executive Customer Relations stating that everything was once again functional, thanking them for the time/effort put into resolving this request.


Not more than literally ~15 minutes after the technician pulled away from the curb, the device hard-locked and refused to even accept ICMP to the inside interface/assigned IPv4-static gateway.


Notified ECR of the failure and was told that they’d have someone onsite the following day.


Less than ~24 hours later I had multiple technicians, including a local VP, respond to my premise (likely trying to find fault with my installation/implementation). I was informed that I wouldn’t be receiving another CG3000DCR, only the CGA4131COM.


To be frank, the CGA4131COM is a very capable device, one that I have zero issue keeping, if it were not for the the fact that it was shipped with broken firmware.


This isn’t conjecture, my opinion, a crazy person rattling nonsense, nor is it my configuration. A nearly ~100 billion dollar company, shipped a broken device. That’s it. It happens. This is a fact.


It took me the better part of a month to not only convince not only ECR/T2 of this fact, but local resources. I’m still not sure how much of them finally seeing the light was simply placation to get me to stop contacting them.


Here’s where we left off:


My last email to ECR and subsequent site-visit was on Sept 25/26th. I was informed that it was now a ‘known issue’ and a new firmware was in the pipeline, slated for testing/deployment within ~2 weeks. However, this wouldn’t apply to me because I’m a static customer that routes their block over RIPv2, which requires a different firmware. This firmware for static customers would be available ‘middle of November’


Needing to move on with life, I accepted this, adding additional cost to my monthly totals with Amazon Web Services to spin up a bastion/testing host for only IPv6. Not only is this inconvenient, but it doesn’t work for the majority of test-cases I’d generally leverage IPv6 for.


As a provider myself who works in the telecommunications space, my needs are significantly different than the average Xfinity/Comcast Business customer. But it cannot be overstated how much this has impacted my workflow.


I just wanted to type this up so that anyone else encountering this issue can rest assured, it’s not you. It’s the modem. I don’t care what response I receive to this, if any, your CGA4131COM has broken firmware. It needs to be escalated to the appropriate parties.


I’m not hopeful this is going to be resolved soon as even the NOC staff looked at this as a ‘dude, fix your configuration’-issue. But I can remain hopeful that this isn’t falling of deaf ears.


I await my boiler-plate/copy-pasta response about how Comcast supports IPv6 and I should real support/KB-document ‘XYZ’ as to how to configure my equipment.


Likely going to shamelessly necro-post any related threads I see with the term ‘CGA4131COM’ because I’ve seen a trend where you prefer to take these threads offline, which negates the entire purpose of a community forum like this.


If anyone within the organization is curious enough to follow up, I’d be happy to provide private details via DM, as long as we agree to continue the brunt of the discussion in an open forum as to benefit others like myself who have met the same brick wall.


For the .00001% of people who made it this far, thanks!


New Member

Re: DHCPv6-PD Worked With CG3000DCR Now Broken With CGA4131COM

I am also having the same issue with this modem. I have a ticket open and hopefully they can exchange out their hardware for something that works

Community Manager
Community Manager

Re: DHCPv6-PD Worked With CG3000DCR Now Broken With CGA4131COM

Thank you so much for taking the time to reach out and welcome to our business forums. I would love to look further into your request and open ticket. Can you please reach out through private message with your first and last name, full service address and account number or phone number and I would be happy to get started. -Comcast_Michelle

0 Kudos