Equipment (Modems,Gateways)
Modems, Gateways, and Networking Devices
Male IT Specialist Holds Laptop and Discusses Work with Female Server Technician. They're Standing in Data Center, Rack Server Cabinet is Open.
Highlighted
New Member

Web server behind Comcast modem (Loopback issue)

I am trying to setup a web server running behind a comcast modem. We can access it from outside our office network. But, if we try to access it using global ip from local area network, it does not work. I guess loopback occurs and we cannot see it. We can access it using local ip instead of global ip.I have gone through all setting on the modem, but i cannot find any setting for loopback. Is there any way to make this work??

 

The firmware version on the modem is as follows.

 

Vendor NameNetgear

Hardware Version1.04

Firmware VersionV1.34.04

 

 

Thanks for your help in advance.

0 Kudos
6 ACCEPTED SOLUTIONS

Accepted Solutions
Highlighted
New Member

Re: Web server behind Comcast modem (Loopback issue)

i have 5 static IPs.

View solution in original post

0 Kudos
Highlighted
Trusted Forum Contributor

Re: Web server behind Comcast modem (Loopback issue)

I don't believe the Netgear supports NAT loopback, which is what you're looking for. You MAY be able to mess around with static routing to make this work, but it might be easier to add a second NIC to the webserver, assign it a static IP within the same internal LAN subnet of the Netgear (which defaults to 10.1.10.0/24), connect that interface to a free ethernet port on the Netgear, and then have the webserver listen on that interface. You would then access the web server via its 10.1.10.x address while you are inside the LAN.

View solution in original post

0 Kudos
Highlighted
Trusted Forum Contributor

Re: Web server behind Comcast modem (Loopback issue)

Ah ok.

 

The IP address of the Comcast modem (aaa.bbb.ccc.ddd in your example) is technically the default gateway for the 5 static IPs you are paying for; it's typically the next address up in the static IP block, so in my previous example of the range 50.60.70.5-10, the gateway address would be 50.60.70.11. If you have any devices configured (either through DHCP from the Comcast modem, as you're doing now, or statically assigned) with an address from within the 10.1.10.x subnet, they appear on the internet as coming from that gateway address.

 

So at the moment, you're technically not using any of your static IPs. What you need to do is configure both routers with separate static IPs from the range that you are paying for; they won't be 10.1.10.x addresses, they'll be global public addresses. Go into their config pages, and set a static address on the WAN interfaces. Set the subnet mask to be 255.255.255.248, and set the default gateway to be that same aaa.bbb.ccc.ddd address. You should not need any port forwarding on the Comcast gateway.

 

I'll use your same example, assume that your static IP range is 216.248.233.5 - 216.248.233.10, with a default gateway of 216.248.233.11

 

Comcase Modem (216.248.233.11)

| --- Router A (216.248.233.5)

| -------- PC A (192.168.a.b)

| -------- PC B (192.168.a.b)

|

| --- Router B (216.248.233.6)

| -------- Web Server (192.168.e.f)

 

Assuming router B was properly forwarding port 80 to the web server, all HTTP requests to http://216.248.233.6 should go to the webserver. Office traffic will exit router A with address 216.248.233.5, and should have no problem accessing 216.248.233.6 (or 216.248.233.7, or any other of your 5 Comcast-provided statics)

View solution in original post

Highlighted
Trusted Forum Contributor

Re: Web server behind Comcast modem (Loopback issue)

No, remove 1-to-1 NAT.

View solution in original post

0 Kudos
Highlighted
Trusted Forum Contributor

Re: Web server behind Comcast modem (Loopback issue)

DHCP can be off, but it shouldnt matter. As long as your routers WAN ports are statically set with 1 of the 5 Comcast provided statics, subnet mask , and gateway, then plugged into 1 of the 4 ports on the comcast gateway, traffic will be routed to/from them correctly.

View solution in original post

0 Kudos
Highlighted
Trusted Forum Contributor

Re: Web server behind Comcast modem (Loopback issue)

LOL yeah, the Comcast gateway contains the proper routing information to know about both your global static subnet, AND its own internal 10.1.10.0 LAN subnet. kinda cool stuff actually.

Glad I could be of help!

View solution in original post

12 REPLIES 12
Highlighted
New Member

Re: Web server behind Comcast modem (Loopback issue)

i have 5 static IPs.

View solution in original post

0 Kudos
Highlighted
Trusted Forum Contributor

Re: Web server behind Comcast modem (Loopback issue)

I don't believe the Netgear supports NAT loopback, which is what you're looking for. You MAY be able to mess around with static routing to make this work, but it might be easier to add a second NIC to the webserver, assign it a static IP within the same internal LAN subnet of the Netgear (which defaults to 10.1.10.0/24), connect that interface to a free ethernet port on the Netgear, and then have the webserver listen on that interface. You would then access the web server via its 10.1.10.x address while you are inside the LAN.

View solution in original post

0 Kudos
Highlighted
New Member

Re: Web server behind Comcast modem (Loopback issue)

train_wreck,

Thanks for your quick reply.

Actually, we can access the websever using local ip with current setup. What I want to do is access the webserver using global ip even from our office. So, i do not think having a second NIC does not solve this problem... what do you think??

0 Kudos
Highlighted
Trusted Forum Contributor

Re: Web server behind Comcast modem (Loopback issue)

No, a second NIC wouldn't let you do that.

 

Tell me, is your internal network using the Comcast gateway as its only router? (e.g., does everyone have 10.1.10.x addresses, and are getting DHCP information from the Comcast gateway?)

 

If so, you could get a separate router, assign its WAN port address with 1 of your 5 Comcast-provided statics, and put everyone in the office behind that router. That way, their traffic will pass through the separate router, get NATted to the external static IP, enter the Netgear and then be passed to the webserver's external static IP.

 

For example, say you have a static IP range 50.60.70.5 - 50.60.70.10:

 

-webserver has static Comcast IP 50.60.70.5, plugs directly into Comcast modem.

-additional router has WAN port with static IP address 50.60.70.6, WAN plugged into Comcast modem.

-additional router has LAN configured with whatever subnet (192.168.10.0/24, for example).

 

IN this case, the web server at address 50.60.70.5 would see traffic coming from your LAN as coming from 50.60.70.6. The netgear should not need any loopback to accomplish this. Let me know if this makes sense for you.

0 Kudos
Highlighted
New Member

Re: Web server behind Comcast modem (Loopback issue)

We are using additional routers after Comcast modem and all PCs in our network are connected under these routers.
So, PCs are getting IP address from DHCP in "additional router".

 

Comcast Modem (aaa.bbb.ccc.ddd)
| --- Router A (10.1.10.x)
|        +--- PC A (192.168.a.b)
|        +--- PC B (192.168.a.c)
|        +--- PC C (192.168.a.d)
|        +--- ...
| --- Router B (10.1.10.y)
|        +--- Web Server (192.168.e.f)
|


Here,
- Our PCs are under "Router A".
- Incoming traffic on Port 80 is forwarded to Routert B (10.1.10.y) and it is forwarded to WebServer.

 

Now, i am on PC A and trying to access Web Sever running under Router B using global IP (aaa.bbb.ccc.ddd).

 

0 Kudos
Highlighted
Trusted Forum Contributor

Re: Web server behind Comcast modem (Loopback issue)

Ah ok.

 

The IP address of the Comcast modem (aaa.bbb.ccc.ddd in your example) is technically the default gateway for the 5 static IPs you are paying for; it's typically the next address up in the static IP block, so in my previous example of the range 50.60.70.5-10, the gateway address would be 50.60.70.11. If you have any devices configured (either through DHCP from the Comcast modem, as you're doing now, or statically assigned) with an address from within the 10.1.10.x subnet, they appear on the internet as coming from that gateway address.

 

So at the moment, you're technically not using any of your static IPs. What you need to do is configure both routers with separate static IPs from the range that you are paying for; they won't be 10.1.10.x addresses, they'll be global public addresses. Go into their config pages, and set a static address on the WAN interfaces. Set the subnet mask to be 255.255.255.248, and set the default gateway to be that same aaa.bbb.ccc.ddd address. You should not need any port forwarding on the Comcast gateway.

 

I'll use your same example, assume that your static IP range is 216.248.233.5 - 216.248.233.10, with a default gateway of 216.248.233.11

 

Comcase Modem (216.248.233.11)

| --- Router A (216.248.233.5)

| -------- PC A (192.168.a.b)

| -------- PC B (192.168.a.b)

|

| --- Router B (216.248.233.6)

| -------- Web Server (192.168.e.f)

 

Assuming router B was properly forwarding port 80 to the web server, all HTTP requests to http://216.248.233.6 should go to the webserver. Office traffic will exit router A with address 216.248.233.5, and should have no problem accessing 216.248.233.6 (or 216.248.233.7, or any other of your 5 Comcast-provided statics)

View solution in original post

Highlighted
New Member

Re: Web server behind Comcast modem (Loopback issue)

I did exactly by following your instruction. But, once i reboot the router, i lost the internet connection.

 

I manually set WAN port IP on "router A", but i guess i need to change the model setting as well?? DHCP on the comast modem still has range of 10.1.10.x. So, there should be a conflication between modem and routert. Should i change this to what ever IP address i have (5 static)?? 

 

By the way, i set up 1-to-1 NAT to associate global ip to each router. Should I not do this??

 

 

0 Kudos
Highlighted
Trusted Forum Contributor

Re: Web server behind Comcast modem (Loopback issue)

No, remove 1-to-1 NAT.

View solution in original post

0 Kudos
New Member

Re: Web server behind Comcast modem (Loopback issue)

How about the DHCP on the comcast modem?? Should I leave it enabled with the range of 10.1.10.x??

I still do not get how the incoming traffic on static ip will forwarded to the router.....

0 Kudos
Highlighted
Trusted Forum Contributor

Re: Web server behind Comcast modem (Loopback issue)

DHCP can be off, but it shouldnt matter. As long as your routers WAN ports are statically set with 1 of the 5 Comcast provided statics, subnet mask , and gateway, then plugged into 1 of the 4 ports on the comcast gateway, traffic will be routed to/from them correctly.

View solution in original post

0 Kudos
Highlighted
New Member

Re: Web server behind Comcast modem (Loopback issue)

It magically works as expected...!!!

Thank you for your support. Really appreciate!!

0 Kudos
Highlighted
Trusted Forum Contributor

Re: Web server behind Comcast modem (Loopback issue)

LOL yeah, the Comcast gateway contains the proper routing information to know about both your global static subnet, AND its own internal 10.1.10.0 LAN subnet. kinda cool stuff actually.

Glad I could be of help!

View solution in original post