Equipment (Modems,Gateways)
Modems, Gateways, and Networking Devices
Male IT Specialist Holds Laptop and Discusses Work with Female Server Technician. They're Standing in Data Center, Rack Server Cabinet is Open.
Highlighted
Visitor

Static IP to Linux Router Configuration

I have a Linux router that handles the outbound connection for our corporate network. It's worked reliably for years with other network providers.

 

We recently had Comcast Business installed with 13 static IPs to take advantage of the speed offered. The installation used a CISCO DPC3939B cable modem. Wireless is turned off (we have our own wireless corporate network). Based on recommendations from Comcast support, I've also disabled DHCP and DNS in the modem so that it's in bridge mode.

 

We have a block of addresses (96.xx.xx.17 - 96.xx.xx.29) assigned to the interface. Gateway address is 96.xx.xx.30.

 

Configuring the adapter and routes using this information only results in RTNETLINK invalid parameter responses. It appears that the ports on the CISCO DPC3939B may be still looking for configurations with default 10.1.10.x network?

 

Is there someone who's successfully configured a LINUX-based router for Comcast Business with a block of static addresses can point me in the right direction?  I can certainly provide more details on the set-up but that may be better done via direct message.

 

Thanks.

0 Kudos
3 REPLIES 3
Highlighted
Trusted Forum Contributor

Re: Static IP to Linux Router Configuration

I have several Linux systems behind a DPC3939B, all of them configured to use addresses in my /29 block, with no issues; actually, our performance improved dramatically with the Cisco, since switching from the POS Netgear. I am using Arch Linux on all of them.

 

To start, which distribution are you using, and what commands have you entered? As well, can you connect a computer directly to the Cisco & allow it to obtain a 10.1.10.x DHCP address, then browse to http://10.1.10.1 and verify that the gateway is actually provisioned with your static IPs correctly? (I did have this problem when I initially had the Cisco installed; the install tech assured me that the IPs would become active "some time in the next 24 hours", but of course he was wrong, and I had to call in to support and get them to re-provision it again.)

0 Kudos
Highlighted
Visitor

Re: Static IP to Linux Router Configuration

 

 

train_wreck - thanks for the reply. I'm not sure how to verify whether the static IP's have been provisioned correctly. There doesn't seem to be the access to the static IP tables in the DPC3939B. I did call COMCAST support and they said that they were there and configured correctly.

 

Here's the background information:

+--------------------+                              /----------------\
|   DPC3939B         |                              |Internal Net    |
| IPs: 96.xx.xx.17 - |        +----------+          | 10.1.1.0/24    |
|      96.xx.xx.29   |-->eth0 | Linux    |eth3----> |                |
| GW: 96.xx.xx.30    |        | router   |          |                |
|Msk: 255.255.255.240|        |          |          \----------------/
+--------------------+        +----------+

 

DPC3939B Configuration:
  WiFi is off
  MoCA is off
  Enable LAN DHCP - unchecked
  Assign DNS Manually - unchecked
  Disable Firewall for True Static IP Subnet Only - checked
  Disable Smart Packet Detection - checked
  Port Forwarding - Disable
  Port Triggering - Disable
  Port Management - Disable all rules and allow all inbound traffic - checked
  DMZ - Disable
  NAT - Disable all
  NO Static Routing entries
  Dynamic DNS - Disable

  WAN IP address:  96.xx.xx.30  (Is this supposed to be the GW address or the first IP in the assigned block?)
  WAN Default GW address:  24.91.16.1    (Obviously different that Gateway IP ... not sure if this is right?)

 

 

------

 

Linux router is SuSE 11

 

Linux Router Setup:

 

Eth0 configuration:
DEVICE=eth0
BOOTPROTO='static'
BROADCAST=''
IPADDR='96.xx.xx.17'
MTU=''
NAME='Gigabit Ethernet'
NETMASK='255.255.255.240'
GATEWAY='96.xx.xx.30'
DNS1='75.75.75.75'
DNS2='75.75.76.76'
IPV6INIT='no'
NETWORK=''
REMOTE_IPADDR=''
STARTMODE='auto'
UNIQUE='rBUF.tRUnA16977'
USERCONTROL='no'
PREFIXLEN=''

 

 

Routing Table Script. Note there is more than one table defined (using a backup network)
but for testing purposes I eliminated the other WAN.

 

#Internal LAN
IF0=eth3
IP0=10.1.1.1
P0=10.1.1.1
P0_NET=10.1.1.0/24

 

#COMCAST
IF1=eth0
IP1=96.xx.xx.17
P2=96.xx.xx.30
P2_NET=96.xx.xx.17/28

 

# main routing
ip route add $P0_NET dev $IF0 src $IP0
ip route add $P1_NET dev $IF1 src $IP1

 

# routing table
ip route add $P1_NET dev $IF1 src $IP1 table T1

 

# allow LAN to be seen by COMCAST
ip route add $P0_NET dev $IF0 src $IP0 table T1

 

# local host
ip route add 127.0.0.0/8 dev lo table T1

 

# Route to only COMCAST
ip route add default scope global next hop via $P1 dev $IF1 weight 10


I immediately get an error with the first "ip route" command - RTNETLINK invalid argument which to me indicates something isn't right in the cable modem configuration (i.e. it the port on the DPC3939B isn't accepting the address information). If I statically configure a Windows laptop to one of the ports I can connect to the Internet. Funny thing is that the DPC3939B says the connected device is a 10.1.10.x connection even though DHCP is not running (or at least the DPC3939B is saying it's not running) and the static IP configuration on the laptop is 96.xx.xx.17 with gateway 96.xx.xx.30 and MASK of 255.255.255.240.

 

 

Any ideas would be helpful.  Appreciate you taking the time to look at this.

 

 

 

0 Kudos
Highlighted
Visitor

Re: Static IP to Linux Router Configuration

Just in case anyone else faces this problem....the issue was that the real IP range is beyond what Comcast tells you. If you have 13 addresses, the block of IP addresses is really 15 (one less than the lowest IP and one higer than the highest IP. The one high is the gateway address). 

 

I was getting the error (RTNETLINK answers invalid argument) when I tried this:

 

ip route add 96.xx.xx.17/28 dev eth0 src 96.xx.xx.17

 

The solution was to change to

 

ip route add 96.xx.xx.16/28 dev eth0 src 96.xx.xx.17

 

You can only use 13 (the range Comcast tells you) but the actual block size is 15.

 

Hope this helps someone avoid the frustration I had.

 

 

0 Kudos