Domain Names/Static IP
Managing, controlling, and support for Custom Domain Names
Back to Top

1-1 NAT Fail (DPC3939B)

Highlighted
Kurtm
Visitor

1-1 NAT Fail (DPC3939B)

I just switched to Comcast Business with 5 Usable static IP’s

I tried to use 1:1 NAT, but receive an error, “Message: The Private IP has been used!”

I cannot map my static IP’s to anything...

 

Anyone else have this issue?

 

My Gateway info is below

 

Model: DPC3939B
Vendor: Cisco
Hardware Revision: 1.0

Community Manager
Community Manager

Re: 1-1 NAT Fail (DPC3939B)

HI Kurtm.  The error message provided in the post usually happens on a duplicate assignment with port forwarding.  Currently there are no 1 to 1 NAT rules active on the device.  If you could post a bit more info on the situation one of our Community Members could possibly assist.  Only include the last octet of the IP addresses involved for security purposes.

 

Thank You

Tnelsom
Contributor

Re: 1-1 NAT Fail (DPC3939B)

It sounds like you may not be using your ip addresses correctly either. With our comcast block of 5 ips we did this. (Obviously 172.16.0.x is not our ip but you get the idea)
172.16.0.6 comcast modem gateway
Block of ips 172.16.0.1 - 172.16.0.5

Cisco router directly connected to the modem statically set to
IP address. 172.16.0.1 (first usable IP address)
Subnet mask 255.255.255.248
Gateway 172.16.0.6

Linux spam filter directly connected to the modem statically set to
IP address 172.16.0.2 (second usable static IP address)
Subnet 255.255.255.248
Gateway 172.16.0.6

Using your ip addresses this way eliminates the need for 1 to 1 nat and eases the load on the modem.

Tip: If you setup a device using the modem 10.1.10.1 network the traffic will go out on the gateway device giving you a 6th IP address.
Example
Linksys wireless router
IP address 10.1.10.10
Subnet mask 255.255.255.0
Gateway 10.1.10.1
This will have a public IP address of 172.16.0.6 and in this case if I wanted to enable outside traffic to access my wireless router I can do a 1 to 1 nat.