Connectivity
Connectivity and managing Your Comcast Business network
Male IT Specialist Holds Laptop and Discusses Work with Female Server Technician. They're Standing in Data Center, Rack Server Cabinet is Open.
chrismccracken
Visitor

>20% Upstream packet loss from Seattle

I am experiencing upstream packet loss in Comcast's network from Seattle. It looks like its at the hop between 68.86.83.2 and 75.149.231.90 (both still on Comcast before Google peering). This is the Comcast route to Google services from my location, and is making my Google Apps usage (Gmail, etc..) inconsistent and unreliable.

 

## Route to Google DNS

 

MacBookPro:~$ traceroute 8.8.8.8
traceroute to 8.8.8.8 (8.8.8.8), 64 hops max, 52 byte packets
1 rtr1 (192.168.254.254) 1.938 ms 9.868 ms 5.775 ms
2 #OBFUSCATED#-static.hfc.comcastbusiness.net (#OBFUSCATED#) 14.126 ms 13.769 ms 16.086 ms
3 73.220.36.1 (73.220.36.1) 20.017 ms 19.769 ms 19.761 ms
4 te-0-2-0-5-ur07.seattle.wa.seattle.comcast.net (68.87.207.49) 19.628 ms 10.023 ms 20.029 ms
5 be-1-ur08.seattle.wa.seattle.comcast.net (69.139.164.134) 20.046 ms
ae-20-0-ar03.burien.wa.seattle.comcast.net (69.139.164.125) 19.498 ms
be-1-ur08.seattle.wa.seattle.comcast.net (69.139.164.134) 19.777 ms
6 ae-2-0-ar03.seattle.wa.seattle.comcast.net (68.86.177.146) 19.757 ms
ae-1-0-ar03.seattle.wa.seattle.comcast.net (68.85.240.94) 19.728 ms
ae-20-0-ar03.seattle.wa.seattle.comcast.net (69.139.164.129) 19.870 ms
7 he-1-8-0-0-10-cr01.seattle.wa.ibone.comcast.net (68.86.94.229) 29.466 ms
he-1-7-0-0-11-cr01.seattle.wa.ibone.comcast.net (68.86.93.5) 19.637 ms
he-1-5-0-0-11-cr01.seattle.wa.ibone.comcast.net (68.86.94.65) 29.812 ms
8 be-14-pe03.seattle.wa.ibone.comcast.net (68.86.83.2) 26.473 ms 22.747 ms 30.082 ms
9 75.149.231.90 (75.149.231.90) 29.823 ms * *
10 209.85.249.32 (209.85.249.32) 12.133 ms 29.687 ms *
11 66.249.94.197 (66.249.94.197) 16.424 ms
66.249.94.199 (66.249.94.199) 19.807 ms 20.060 ms
12 216.239.46.208 (216.239.46.208) 70.089 ms * 30.039 ms
13 216.239.48.165 (216.239.48.165) 29.978 ms 19.681 ms 30.181 ms
14 * * *
15 * google-public-dns-a.google.com (8.8.8.8) 25.693 ms 29.495 ms

 

 

## Last good hop

 

MacBookPro:~$ ping -c 100 -s 1400 68.86.83.2

<snipped>

--- 68.86.83.2 ping statistics ---
100 packets transmitted, 100 packets received, 0.0% packet loss
round-trip min/avg/max/stddev = 11.975/20.787/31.020/5.186 ms

 

 

## Bad hop

MacBookPro:~$ ping -c 100 -s 1400 75.149.231.90

<snipped>

--- 75.149.231.90 ping statistics ---
100 packets transmitted, 78 packets received, 22.0% packet loss
round-trip min/avg/max/stddev = 11.525/28.143/67.295/11.911 ms

 

0 Kudos
5 REPLIES 5
chrismccracken
Visitor

Re: >20% Upstream packet loss from Seattle

While on the phone with Comcast tech support, this problem ceased. The first agent I talked to said I could not email her my ping/traceroute data, and that there was no problem on their end and I should buy signature support. Smiley Frustrated The second agent I talked to actually was trying to be helpful and was willing to document the issue and send it up the food chain, when the issue resolved itself. I guess a router admin somewhere found the problem and fixed it.

0 Kudos
chrismccracken
Visitor

Re: >20% Upstream packet loss from Seattle

...and the problem is back 5 minutes after I get off the phone with tech support. Comcast, you are not providing business-grade service today! Smiley Mad

0 Kudos
FireSlash
New Member

Re: >20% Upstream packet loss from Seattle

I've also been getting some intermittent loss from Kirkland since yesterday. Seems a bit better this morning, but still lossy. This is impacting a lot of hosts, but I'll compare with op for data's sake.

 

mtr 8.8.8.8

Host%SentRecvBestAvrgWrstLast
192.168.1.101281280000
No response from host1002500000
te-0-0-0-5-ur06.bellevue.wa.seattle.comcast.net01281287122512
ae-18-0-ar03.seattle.wa.seattle.comcast.net012812881810010
he-1-4-0-0-11-cr01.seattle.wa.ibone.comcast.net01281289153113
be-10-pe03.seattle.wa.ibone.comcast.net01281287133012
75.149.231.90311511210157221
209.85.249.3401281289188312
66.249.94.1971284749142827
216.239.46.20814847316213717
216.239.48.16710928315203321
No response from host1002500000
google-public-dns-a.google.com2071570202922
0 Kudos
chrismccracken
Visitor

Re: >20% Upstream packet loss from Seattle

It is also affecting a lot of destination hosts for me besides Google. Google DNS was the easiest test case to provide data on.

0 Kudos
chrismccracken
Visitor

Re: >20% Upstream packet loss from Seattle

Looks like its a pretty widespread outage affecting a ton of people in the Puget Sound region, and at least someone at Comcast knows about it:

 

http://www.reddit.com/r/Seattle/comments/1q9cwk/anyone_else_having_comcast_issues_today/


From: https://twitter.com/ComcastWA/status/399292622168023040
"We apologize to Internet customers affected by a routing issue in the West; engineers are working it now"

0 Kudos