Connectivity
Connectivity and managing Your Comcast Business network
Male IT Specialist Holds Laptop and Discusses Work with Female Server Technician. They're Standing in Data Center, Rack Server Cabinet is Open.
Highlighted
Visitor

Services Not Installed

I just got business internet and the hardware was installed yesterday. I paid for a static IP address, but when I try to access my website through it, it doesn't load. I have internet and can access other sites though. My website also loads on my phone over mobile data, but not over Wi-Fi.

When I try to manage my account online, I'm told that my services have not been installed yet. Is that something that just takes time, or is something wrong with my account?
0 Kudos
Reply
3 REPLIES 3
Highlighted
Official Employee

Re: Services Not Installed

Hi there, thank you so much for taking the time to reach out to the Digital Care Team here through the forums.  I am so sorry to see that you are having issues with the static IP after the install. I know how frustrating this can be and you have reached the right team to help get this taken care of. Can you please send us a private message with your name, the full address, and phone/account number? 

0 Kudos
Reply
Highlighted
Visitor

Re: Services Not Installed

I apologize, but how do I send a private message? I can't seem to find the option.

0 Kudos
Reply
Highlighted
Official Employee

Re: Services Not Installed

I am sorry that you are having trouble locating it. You can just click on my handle and select the option to send private message. I will also send you a private message directly that you can respond to as well if you would prefer that option. 

0 Kudos
Reply