Connectivity
Connectivity and managing Your Comcast Business network
Male IT Specialist Holds Laptop and Discusses Work with Female Server Technician. They're Standing in Data Center, Rack Server Cabinet is Open.
Highlighted
Visitor

Remote Desktop Issue

We have several employees that access our Comcast Business Service via RDP.  Last week, one of our employees switched from Uverse to Xfinity home and now is unable to access our company server via RDP.  IP address has not changed and the employee is able to use a hot-spot from his phone to access with NO problem but if he uses his home computer connected through Xfinity home, he is blocked.

 

Any ideas what is going on?

 

Thanks.

0 Kudos
Reply
3 REPLIES 3
Highlighted
Official Employee

Re: Remote Desktop Issue

A blocked port was my first instinct so I checked and it looks like usually RDP uses port 3389 which isn't one that we block (https://comca.st/2XBNMmM ). Is there a particular error or any other information that might point us towards a solution? We appreciate you taking the time to reach out to us about this and want to help 🙂 

0 Kudos
Reply
Highlighted
Visitor

Re: Remote Desktop Issue

Gina,

 

Thank you for your response.  I found out what the issue was last night from home but I have to admit that I am perplexed why Comast/Xfinity would cause this issue.

 

My first thought was to try a VPN tunnel from the house to the office server...BLOCKED.  So I said, let's try something interesting and I TURNED OFF the Advanced Security feature of your new modem. Boom! the VPN connected so I said, maybe....  I then tried the RDP without the VPN and Boom, again it went right through.  I turned the Advanced Security back on and the VPN & RDP quit working.

 

So, after numerous calls with level two support telling me that I needed to contact our IT dept or contact Microsoft I have proven that in fact Comcast and the Advanced Security feature is the actual culprit.  That said, how do we solve this problem without having to turn the AS off & on all the time?

 

Thank you for your help.

0 Kudos
Reply
Highlighted
Official Employee

Re: Remote Desktop Issue

Ah! That makes sense; our xFI Advanced Security feature is meant to protect against and weed out threats for our residential customer's networks (https://comca.st/2Vzjezp ) and so it makes sense that the RDP was recognized as one. There is the option of configuring the Port Forwarding (https://comca.st/2VwVo7h ) or setting up a DMZ as a workaround. If neither of those work, I would recommend having him reach out to our residential team directly (https://comca.st/3aaYZxf ) so they can look into the modem's setup. 

0 Kudos
Reply