Connectivity
Back to Top

Extremely Slow Download Speeds

Highlighted
stevencheeverperry
Occasional Visitor

Extremely Slow Download Speeds

We have changed our internet speeds several different times in the last month. Comcast reps would recommend this speed and other rep would recommend that speed. Finally, I had enough and I went back to the 150/20 that I orginally had. Currently, our speed is 55.79/23.54 using ComCast Business Speed Test Tool. That speed is way off from the 150 we are supposed to be getting. I contacted support by phone on 04.14.2015 and Dustin stated we need a NetGear modem to handle the 150/20. I told him the modem we have is the one ComCast brought out on March 4th, 2015 when we orginally had the 150/20. He then stated he would submit a ticket to tier 2 and they would call me back within 4-8 hours. That didn't happen. I called today and Kokebe stated she saw some trouble on the provisioning side. I did explain to her that our speeds have been changed several times since March 4th, 2015 due to reps making suggestions. I finally put my foot down and I am staying on the 150/20 speeds. She said she put all the details in the ticket to tier 2.

 

When we first had the 150/20 installed, we were getting around 170/25. Since we are back on the 150/20, our speeds are way off from that. Today's phone support and I both believe the reason why we are getting the 50 speeds is because the system is confused due to all the speed changes.

 

We are setting up BVE(Business Voice Edge) and they are showing we have the 50/10 speed. When I log into my business account, it says we have the 100/20 speeds. Something is wrong in the provisioning. I sure hope someone can get this issue fixed so we can continue with the Business Voice Edge setup and get the discount applied to the account for having the 150/20 with Business Voice Edge. 

 

If any Comcast expert can please check into this, that would be great. Thank you very much!