Connectivity
Back to Top

CRITICAL: packet loss on specific comcast hop

joweaver88
New Member

CRITICAL: packet loss on specific comcast hop

Ok we are running a proprietary video game streaming service from a server in Fremont, CA to our office in Los Altos, CA. The service uses the RTP protocol on port 51512 and uses approximately 8 Mbps per stream (at the moment we are only doing one stream at a time for testing). Anyway we are experiencing large amounts of packet loss which is making our service unusable. We have monitored the route using WinMTR and have determined a single hop along the path that is losing 66% of the packets. We suspect that this hop is some sort of deep packet inspection device that is incorrectly flagging our traffic as bad and thus disgardng the packets.

 

Again the stream is 8 Mbps, the bandwidth of our server connection is 100 Mbps down and 100 Mbps up and the bandwidth of our office connection is 50 Mbps down and 10 Mbps up (confirmed with various speed test applications). So this is *not a bandwidth issue.

 

It is important that we not only fix the issue on this route but also come up with a solution that will work nationally because when we roll out our service (we are in development at the moment) it will need to function through all of comcast's systems.

 

Here is a link to a google doc of the WinMTR log.

 

https://drive.google.com/file/d/0B-o76Ok7-w_CNUxwZHAxMUs4ZVE/edit?usp=sharing

 

Please note the entry for the hop c-24-130-215-217.hsd1.ca.comcast.net you will notice 66% packet loss at that specific device.

joweaver88
New Member

Re: CRITICAL: packet loss on specific comcast hop

Also I know this just a forum and this will need to eventually make its way to a high tier tech support group. However considering that it took me two 30 minute phone calls to tech support just to get them to change the email on my account... I think this issue is WAY out of their league. There is no way I can adequately explain this issue to someone over the phone who is going to have absolutely no clue what I am talking about. I need a way to get this problem into the hands of senior tech support quickly and efficiently (even if we have to pay for extra support). I do not have time to spend an entire day struggling through automated phone systems and first tier support reps... not trying to be rude, I am just being realistic.

Community Manager
Community Manager

Re: CRITICAL: packet loss on specific comcast hop

Hello joweaver88,

 

Welcome to the forum.

We have engaged the Regional Support to assist you with this issue.

 

Thank You

joweaver88
New Member

Re: CRITICAL: packet loss on specific comcast hop

THANK YOU SIR!!! You are a gentleman and a scholar! Smiley Very Happy

joweaver88
New Member

Re: CRITICAL: packet loss on specific comcast hop

They closed the ticket without even giving me a chance to respond now I am steaming mad!! Ok so the winmtr results arent a tell all, but our own internal packet loss calculation is showing 1000s of lost packets over a short time frame and the video is horrendous with distortions!! THERE IS PACKET LOSS!!!!!!!!!!!!!!!!!!!!!!

 

I do NOT appreciate being dismissed like that!! If tier 2 cant handle themselves then send me to tier 3, I will not tolerate having a ticket closed on me without them even giving me a chance to respond... especially considering they emailed me from a "do not reply" email address. Thats flat out BS.

 

Sorry to burst your bubble gentleman but one of your routers is dropping our packets, plain and simple.

joweaver88
New Member

Re: CRITICAL: packet loss on specific comcast hop

Geez all I want is to be able to open a *two way email dialogue with tier 2 or 3 in order to figure this problem out... what kind of customer service is this?

Trusted Forum Contributor

Re: CRITICAL: packet loss on specific comcast hop

Just so I understand, you're seeing packet loss between your two locations? If so, would you mind running fresh MTR's, one inbound and one outbound would help. 

 

It's very possible Comcast is overloading one of their links. It's pretty common for ISP's to do this and to delay needed upgrades. They especially delay upgrades around the holiday season since they don't want to take anyone offline. Now that the holiday season is over upgrades should start getting processed. Assuming that is your problem it should go away...until another upgrade is needed. 

 

O, I also live in California and seeing a packet loss issue. Tier II also closed my request without answering me Smiley Sad