Connectivity
Connectivity and managing Your Comcast Business network
Back to Top

Android suddenly not synching with Comcast Exchange

SOLVED
edunne
New Member

Android suddenly not synching with Comcast Exchange

My Samsung Galaxy S3 has been successflyy synching with my company's Exchange server hosted by Comcast for more than a year.  Yesterday it suddenly will not sync anymore. Disgnostics - All server settings are correct, auto sync is on, iPad synchs, can view Exchange email/calendar on web on S3, popped battery, restarted.  What is happening? 

Accepted Solution

Re: Android suddenly not synching with Comcast Exchange

Having the same problem, using Touchdown on Android and an activesync connection. Something's borked... My connections are rejected because there is "no peer certificate." Any Comcast admins care to comment?
View solution in context
Accepted Solution

Re: Android suddenly not synching with Comcast Exchange

I have this problem as well.  It started sometime on Wednesday.  Trying to contact Comcast Technical support led me into the realm of the absurd.  Apparently now, in order to even report a problem like this requires a subscription to Signature Support, starting at $29.95 a month.

 

I am so angry!!!

 

But, in order to continue to connect to an exchange server on your Android device, you'll need to enable "Accept all SSL Certificates" on the account ("Incoming settings").  They've apparently screwed with their SSL certificate, perhaps in preparation to replace it on the 29th of July (the date it shows it will expire).

 

iOS devices don't seem to have a problem accepting the invalid SSL crt.

 

My daily driver is a webOS Pre 3. If you use a browser on any webOS device and go to the url you enter for the Exchange Server, a warning will popup asking if you want to trust the certificate.  If you tap on "Trust Always", the problem should go away.

 

I hope this helps someone.

View solution in context
Accepted Solution

Re: Android suddenly not synching with Comcast Exchange

This is the problem, which is apparently not happening on all comcast servers:

Comcast.net is run by "unknown".

 

comcasterror.jpg

View solution in context
Accepted Solution

Re: Android suddenly not syncing with Comcast Exchange

I'm not following what you guys are saying is the solution to this.  I have a Windows Phone that's been down for two days now as a result of this exact issues.  Are there any resolutions?  I just got off of the phone with Comcast support and they are clueless on how to resolve this.  They have just escalated me to tier 2 support. 

View solution in context
Accepted Solution

Re: Android suddenly not syncing with Comcast Exchange

I don't know much about Windows Phones.

 

A Windows 8 phone should give you the option to install the untrusted certificate but you might need to recreate the account in order to get the option to install the untrusted certificate.

 

On a Windows 7 phone, you might try using the browser on your phone to get the Certificate.  On you phone's browser, enter the Exchange Server url, e.g., "https://mail.mp02.comcast.net". If you get popup asking if you want to trust the website, tap something like "Trust Always" which should allow you to install the certificate on your phone. 

 

 

Or instructions from this link might work:

 

"In order to make Windows Phone 7 trust an otherwise untrusted certificate authority, you have to jump through a few hoops. The first thing that you have to do is to set up an e-mail account on the device that does not depend on SSL encryption. For example, you might link a Windows Live Hotmail account to the Phone.

 

"After doing so, you can e-mail the CA certificate to the account that you have set up on the phone. When the message arrives, just open the attachment and the certificate will be installed, and ActiveSync should begin working.

 

"Of course, things are rarely as simple as they seem. There is one major caveat to the method that I just explained. Windows Phone 7 only recognizes two certificate formats: .CER and .PFX. Normally if you export a CA certificate it will be in .CRT format. If this happens, then you must rename the certificate so that it uses a .CER extension."

 

In order to get the certificate, go to your Exchange Server website on your PC, then (using Firefox): Click on the Lock icon in the browser> More Information>View Certificate>Details>Export. So then you will need to rename the "exchange.businessclass.comcast.net.crt" to "exchange.businessclass.comcast.net.cer" and e-mail it to your phone as instructed above.

 

I've also tried to get Comcast to Acknowledge the problem (After being told repeatedly that it isn't a Comcast problem, which it obviously is!).  There is supposedly a ticket issued.

View solution in context
Accepted Solution

Re: Android suddenly not synching with Comcast Exchange

i am having the same problem.  i have called comcast as well and they say it is a problem with outlook, is there any systems admins that can enlighten us with what to do?

View solution in context
Accepted Solution

Re: Android suddenly not synching with Comcast Exchange

How did you get your Android phone to sync to comcast e-mail account?  I have a custom domain name (company.com) but I get all the way to the page where I put in my DNS info and can go no further.  I get a message that my username/password is incorrect.  Do you sync through Exchange ActiveSync?

View solution in context
Accepted Solution

More on android phone issue

Haven't had any responses so I thought I'd add some info.  My company uses Comcast business class for its e-mail.  I am not technically literate but we have out own domain name (that is, @Company.com) but we don't have an e-mail server and go through Comcast.  I have tried every possible way to sync my GalaxyIII android phone to Comcast but when I reach the final "continue" after putting in what I think is the right DNS info, I ultimately get a message that my username or password is incorrect.  I'm trying to do this through Microsoft Exchange ActiveSync, and the certificate for mail.ch4.comcast.net (MEAS) expired 7/30/13.

 

Anyone have any idea how I can get my comcast business messages on my phone?

 

John C

View solution in context
Accepted Solution

Sync Android phone to E-mail on Comcast

Have an Samsung Galaxy III running Android 4.1.2.  I'm trying to sync to my comcast business e-mail account, which uses my company's domain name.  I have followed the Comcast on-line instructions (which pictoral steps appear slightly different on my phone from those on the website) and can get to the stage where I enter the DNS info to sync up.  When I hit "next" I first get a certificate warning (out of date) but continue through this and get a mesage "Username/Password incorrect."  I know they are not so does anyone have any thoughts?

 

John C

View solution in context
Accepted Solution

Re: Android not syncing with Comcast Exchange

Did this writer--who posted in August 2013--ever get an answer?  I have the exact same problem--custom Comcast exchange address and I cannot sync with Android!   Did anyone overcome this problem?  I was wondering if it was the port that seems to be the default that is inserted by the phone --443.  Is 443 the right port?  Thank you.

View solution in context
jspencer
New Contributor

Re: Android suddenly not synching with Comcast Exchange

Having the same problem, using Touchdown on Android and an activesync connection. Something's borked... My connections are rejected because there is "no peer certificate." Any Comcast admins care to comment?
Kayphoonstar
Visitor

Re: Android suddenly not synching with Comcast Exchange

I have this problem as well.  It started sometime on Wednesday.  Trying to contact Comcast Technical support led me into the realm of the absurd.  Apparently now, in order to even report a problem like this requires a subscription to Signature Support, starting at $29.95 a month.

 

I am so angry!!!

 

But, in order to continue to connect to an exchange server on your Android device, you'll need to enable "Accept all SSL Certificates" on the account ("Incoming settings").  They've apparently screwed with their SSL certificate, perhaps in preparation to replace it on the 29th of July (the date it shows it will expire).

 

iOS devices don't seem to have a problem accepting the invalid SSL crt.

 

My daily driver is a webOS Pre 3. If you use a browser on any webOS device and go to the url you enter for the Exchange Server, a warning will popup asking if you want to trust the certificate.  If you tap on "Trust Always", the problem should go away.

 

I hope this helps someone.

Kayphoonstar
Visitor

Re: Android suddenly not synching with Comcast Exchange

This is the problem, which is apparently not happening on all comcast servers:

Comcast.net is run by "unknown".

 

comcasterror.jpg

tgruebl
New Member

Re: Android suddenly not syncing with Comcast Exchange

I'm not following what you guys are saying is the solution to this.  I have a Windows Phone that's been down for two days now as a result of this exact issues.  Are there any resolutions?  I just got off of the phone with Comcast support and they are clueless on how to resolve this.  They have just escalated me to tier 2 support. 

Kayphoonstar
Visitor

Re: Android suddenly not syncing with Comcast Exchange

I don't know much about Windows Phones.

 

A Windows 8 phone should give you the option to install the untrusted certificate but you might need to recreate the account in order to get the option to install the untrusted certificate.

 

On a Windows 7 phone, you might try using the browser on your phone to get the Certificate.  On you phone's browser, enter the Exchange Server url, e.g., "https://mail.mp02.comcast.net". If you get popup asking if you want to trust the website, tap something like "Trust Always" which should allow you to install the certificate on your phone. 

 

 

Or instructions from this link might work:

 

"In order to make Windows Phone 7 trust an otherwise untrusted certificate authority, you have to jump through a few hoops. The first thing that you have to do is to set up an e-mail account on the device that does not depend on SSL encryption. For example, you might link a Windows Live Hotmail account to the Phone.

 

"After doing so, you can e-mail the CA certificate to the account that you have set up on the phone. When the message arrives, just open the attachment and the certificate will be installed, and ActiveSync should begin working.

 

"Of course, things are rarely as simple as they seem. There is one major caveat to the method that I just explained. Windows Phone 7 only recognizes two certificate formats: .CER and .PFX. Normally if you export a CA certificate it will be in .CRT format. If this happens, then you must rename the certificate so that it uses a .CER extension."

 

In order to get the certificate, go to your Exchange Server website on your PC, then (using Firefox): Click on the Lock icon in the browser> More Information>View Certificate>Details>Export. So then you will need to rename the "exchange.businessclass.comcast.net.crt" to "exchange.businessclass.comcast.net.cer" and e-mail it to your phone as instructed above.

 

I've also tried to get Comcast to Acknowledge the problem (After being told repeatedly that it isn't a Comcast problem, which it obviously is!).  There is supposedly a ticket issued.

rae
Visitor

Re: Android suddenly not synching with Comcast Exchange

i am having the same problem.  i have called comcast as well and they say it is a problem with outlook, is there any systems admins that can enlighten us with what to do?

jcnyul
New Member

Sync Android phone to E-mail on Comcast

Have an Samsung Galaxy III running Android 4.1.2.  I'm trying to sync to my comcast business e-mail account, which uses my company's domain name.  I have followed the Comcast on-line instructions (which pictoral steps appear slightly different on my phone from those on the website) and can get to the stage where I enter the DNS info to sync up.  When I hit "next" I first get a certificate warning (out of date) but continue through this and get a mesage "Username/Password incorrect."  I know they are not so does anyone have any thoughts?

 

John C

jcnyul
New Member

More on android phone issue

Haven't had any responses so I thought I'd add some info.  My company uses Comcast business class for its e-mail.  I am not technically literate but we have out own domain name (that is, @Company.com) but we don't have an e-mail server and go through Comcast.  I have tried every possible way to sync my GalaxyIII android phone to Comcast but when I reach the final "continue" after putting in what I think is the right DNS info, I ultimately get a message that my username or password is incorrect.  I'm trying to do this through Microsoft Exchange ActiveSync, and the certificate for mail.ch4.comcast.net (MEAS) expired 7/30/13.

 

Anyone have any idea how I can get my comcast business messages on my phone?

 

John C

jcnyul
New Member

Re: Android suddenly not synching with Comcast Exchange

How did you get your Android phone to sync to comcast e-mail account?  I have a custom domain name (company.com) but I get all the way to the page where I put in my DNS info and can go no further.  I get a message that my username/password is incorrect.  Do you sync through Exchange ActiveSync?

Kayphoonstar
Visitor

Re: Android suddenly not synching with Comcast Exchange

What are you using for your login name?  It should be 'yourusername@company.com' not just 'yourusername'.  That's the only thing I can think of that might be causing your issue.  The SSL issue seems to have been resolved.

Highlighted
PA_PA
New Member

Re: Android not syncing with Comcast Exchange

Did this writer--who posted in August 2013--ever get an answer?  I have the exact same problem--custom Comcast exchange address and I cannot sync with Android!   Did anyone overcome this problem?  I was wondering if it was the port that seems to be the default that is inserted by the phone --443.  Is 443 the right port?  Thank you.