Connectivity
Back to Top

20-40% packet loss over the past two months

_sam
Visitor

20-40% packet loss over the past two months

We have a business account and we started experiencing packet loss around two months ago. Despite calling the customer support numerous times, it seems Comcast just doesn't care.


Here are the things that have been done so far:

 

- 5 times technicians (either contractors or in-house technicians) visited our office to check the modem, line and any other equipments.
- 3 times modem was replaced (no effect)
- 2 times we were told the street construction might have affected the line and it'll be fixed soon. (It wasn't)
- 3 times we were told the modem is good and the line is fine so comcast should send a "network engineer" to check but then again
the next guy shows and they repeat the same thing over and over again.
- 9 times we called customer service. 3 times the line was dropped so we had to repeat our story again. Once we get to an agent
they keep repeating the same instructions (resting the modem, turing of wifi, etc.) over and over again.

 

Here is a screenshot of the packet loss over the past 7 days:

 

Screen Shot 2019-01-02 at 8.45.07 AM.png

 

This is extremely frustrating as we have a business which relies on the internet heavily.

Official Employee

Re: 20-40% packet loss over the past two months

 

Hi _sam and welcome to the business forums.

 

I am sorry to hear about your service issues. I would like to help with any latency or packet loss that may be occurring. I'll need your information in a private message to review. Please private message me your first and last name, the name of your business, the full address of your business location and the phone number associated with your business account. 

_sam
Visitor

Re: 20-40% packet loss over the past two months

So I did send my info via a private message but I'm getting the same answer that I was getting over the last two months. This time instead via a private message. Such a horrible experience with comcast.