Business WiFi
Back to Top

Securing Business WiFi

JerryG
New Member

Securing Business WiFi

Although a password is assigned to our WiFi, people can still access the signal and network without using any credentials.  I've tried changing the password and saving the changes, but new devices can still access without using a password.  Not long after I changed the password in the Comcast Business admin page, the power went out, so even though the router had to physically restart, there's still no request for new users to input credentials to use the signal.  What step(s) am I missing to activate the secured access?  Thanks for your help!

Trusted Forum Contributor

Re: Securing Business WiFi

Hello JerryG and welcome,

 

If you have a Comcast Gateway (CG) DPC3939B, you have both public and private wifi. Your private wifi is WPA2 network encrypted passcode such that if you set either your 2.4 Ghz or 5 Ghz passcodes, then ONLY users that are provided this passcode are able to login and have Internet Access. Now your public wifi (xfinitywifi hotspot) is typically only accessible using business or residential email address and password or using non-comcast user limited access.

 

Now I believe your issue is with once you connect using any wireless device, you can save that connection so that the next time your wifi device will just connect.  That is a wireless device specific feature and the fiirst time you connect you still must enter in the network passcode for private or email address and password for public.

 

Hope this helps you out.

JerryG
New Member

Re: Securing Business WiFi

Hi VBSSP-RICH,

Even though we have a password assigned to the 2.4 Ghz private WiFi, it's still showing up on devices as unlocked and completely open.  I have disconnected devices and had them "forget" the connection; when I search for available connections with a device that's been connected, our private WiFi is visible - and without a lock.  When I tell it to connect, I'm not prompted for a passcode and I know I should be...any suggestions for possible solutions?

Thanks,

Jerry

Trusted Forum Contributor

Re: Securing Business WiFi

The issue that you are dealing with is device specific with the Operating System network connection after it have been authorized to connect to your private wifi because the user of that device was provided the network encryption passcode  beforehand. The only thing that can be done to lock down your private wifi is to change your private wifi network encryption passcode as often as you deem necessary. This will force any previously connected device to re-login on the bassis of your passcode reset frequency.

 

  

JerryG
New Member

Re: Securing Business WiFi

Hi VBSSP-RICH,

I really appreciate you taking the time to respond; the uncommon nature of this problem makes it a little frustrating.  I changed the password and no devices had to re-login, which is what prompted me to post in the forum because it doesn't make sense.  The wireless symbol also still shows an unsecured/unlocked connection (whereas locked WiFi shows the padlock, or something similar, symbolizing that the network will require authentication to connect).  I assume that I have an incorrect setting somewhere but I can't locate where it is.  Thanks again for your help!

Jerry

WGF00D
New Member

Re: Securing Business WiFi

I am having the exact same problem. I had a new Cisco DPC3939B installed this week and today I am trying to reconfigure the 2.4Ghz to use for employee cell phones and laptops that do not need LAN access. I changed the SSID and the password and I am having the same problem, the modem is not requiring the password and the SSID is showing as unsecured. I tried changing security types, different passwords, and turning it off and on. This is not a problem with the operating system that is connecting to the SSID, it is a problem with the modem not enforcing the use of the network password. I wonder if this is a firmware problem? My modem was installed on Tuesday (5/26), so I would assume it has the latest firmware version installed.