Business VoiceEdge ®
A cloud-based, virtual PBX service loaded with calling features
People in operations center talking on Landline phone. Operators in the office.
New Member

Headset Configuration

There was some kind of recent configuration change to our Polycom VVX 310. My Jabra GN9125 headset no longer works correctly. The headset mode is not consistent between the phone and headset. When I take the headset out of the charging cradle, the headset is on, but not connected to the phone. When I hit the headset button on the phone, then the phone is ready for the headset, but that turns off the headset. They seem to be on opposite pages. I have tried to reset and restart with no success. Here is one problem I see. The instructions are below, but the text in red are menu options no longer available on my VVX 310 phone.


Setting the Phone Analog Headset Options
You may set the phone analog headset option locally through the phone.
To set the analog headset option on your phone:
1. Navigate to the Analog Headset menu (Menu > Settings > Basic> Preferences > Headset> Analog Headset).
2. Select the appropriate headset mode:
• Choose Regular Mode (default) if no compatible headset is attached.
Choose Jabra DHSG if an EHS compatible Jabra headset is attached with an EHS cable or adapter.
• Choose Plantronics Mode if an EHS compatible Plantronics headset is attached with an EHS cable or adapter.
• Choose Sennheiser Mode if an EHS compatible Sennheiser headset is attached with an EHS cable or adapter.


Can anyone help me configure my headset with the new firmware recently installed? I've hung up on so many people trying to get this thing working. It has been rendered useless at this point. We have 7 of them in our office and we're dying without hands free. 




0 Kudos
Respected Member

Re: Headset Configuration

Hello JD_Smith and welcome to forums,


I apologize for any frustration this has caused you. I am currently engaging with support teams to alert them of this issue. In the mean time a few thoughts come to mind on trying to resolve this. First thought is to try and offset your rest and restart process. I am not sure which order you tried but 3 suggestions. 1) Restart phone completely then reset the headset 2) Reset the headset while restarting the phone 3) rest headset completely then restart phone. Due to the recent firmware push I do not have complete information on how we resolve this and I am working to find answer as soon as possible. When I do gather the proper information I will post it here. For the interim here is the user guide for the both the Polycom system and the Jabra headset. I have also included a youtube link on how to soft rest the Jabra headset. Again I apologize for any inconvenience this has caused you.


Polycom User Guide


Jabra User Guide


Rest Jabra GN9125

0 Kudos