Business Voice
Comcast Business high-quality Voice over IP service support
People in operations center talking on Landline phone. Operators in the office.
Highlighted
New Contributor

Outgoing calls double ring

When we make outgoing calls, we hear 2 rings on the other end.  Sometimes when someone picks up, the call quality isn't very good.  If the number we're calling happens to be disconnected, there is still ringing going on while the "this number is disconnected" message is playing.  I guess we're still able to make and receive all our calls, it's just pretty annoying.  Is there some kind of reset or something that can be done to stop this?

0 Kudos
1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted
Trusted Forum Contributor

Re: Outgoing calls double ring

Hello 2Frustrated and welcome,

 

Your Comcast Digital Voice (CDV) service should not be operating as you indicated and let's see if we can ge this resolved for you.  First, you have an Arris telecom modem that you can perform a full Power on reset by 1.) removing the backup Battery, then 2.) unplugging the power cord for 30 seconds. Then install the battery backup battery and plug the power cord back into a power receptacle. This will initialize the modem and perhaps fix your issue.

 

However, if it does not resolve you problem then call 800-391-3000, use technical option,provide your Comcast account number and inform the technical agent of your issue and your reset your telecom modem, then request to have a technician be dispatched to your business site for diagnosis and resolutionof this issue.

 

Hope this helps you out.  

View solution in original post

0 Kudos
1 REPLY 1
Highlighted
Trusted Forum Contributor

Re: Outgoing calls double ring

Hello 2Frustrated and welcome,

 

Your Comcast Digital Voice (CDV) service should not be operating as you indicated and let's see if we can ge this resolved for you.  First, you have an Arris telecom modem that you can perform a full Power on reset by 1.) removing the backup Battery, then 2.) unplugging the power cord for 30 seconds. Then install the battery backup battery and plug the power cord back into a power receptacle. This will initialize the modem and perhaps fix your issue.

 

However, if it does not resolve you problem then call 800-391-3000, use technical option,provide your Comcast account number and inform the technical agent of your issue and your reset your telecom modem, then request to have a technician be dispatched to your business site for diagnosis and resolutionof this issue.

 

Hope this helps you out.  

View solution in original post

0 Kudos