Skip to content

New Member


1 Message

Thu, Sep 9, 2021 7:28 AM

I need help, on how to correctly setup the Comcast Business router and my local linux web server, with port-forwarding, using static ips:

Hello there,

About a week ago I upgraded to the Comcast Business service, which comes with the high-end Comcast Business router, some static ip addresses, and some other features.

Anyways, I setup a linux machine as a web server, which I installed the LAMP stack on, and got a basic WordPress site up and running.

1st I'll explain the steps I took, up too the point that I ran into some issues!

So, after I got a basic WordPress site up and running on a linux machine and did some troubleshooting, I finally made it to the point where I could view the site on my local area network, from my other devices on the network, like my laptop, desktop, and cell phone.

The next step that I did was assign a static ip address to the linux machine, it did not work initially, but, after I also assigned the default gateway static ip address to the linux machine as well, I was finally able to view the linux machine on the LAN again. Running the `ip address` command in the terminal showed the assigned static ip addresses. So it looks like the linux machine's configuration is good to go.

The step where I got stuck at, and have issues with, is configuring the router to do port-forward, using the assigned static ip addresses. I signed into the router using the router's public ip address, then through the tabs: Advance>Port-Forwarding, from there I tried to assign port-forwarding to the linux machine, using it's assigned static ip addresses, but, it threw the error: `ip address is out of range`?

I've been reading a bunch of Comcast issues online, and it seems like with the recent hardware/software upgrades, DHCP by default only allows port-forwarding from within a specific ip address range?

I'm not sure what steps need to be done for my particular setup?

From what I've read online, some of the options are:

  1. Configure the DHCP range to include the assigned static ip addresses, so that they can be used in the port-forwarding options.

  2. Reserve the static ip addresses, so that they can be used with port-forwarding. I have never done this before, and don't know where the options for this configuration are in the routers settings?

  3. Disable DHCP on both the router and linux server? I haven't tried this, because I don't want to accidentally break something and lose access to the router.

From here, I have no idea, setting a linux server with a router's port-forwarding mechanism enabled, using static ip addresses, should be a simple process, it's frustrating being stuck like this! I really need to get this web server hosting, and connected to the internet.

Note: I've already talked to at least 5 IT people from Comcast Business, and none of them were able to help me solve this issue!

I almost forgot to mention, the static ip addresses that I'm trying to setup are ipv4.

Thanks in advance for the help!

Research links:


Official Employee


18 Messages


Hi @user_ccf72a, thank you for reaching out to us here on the Business forums. I understand you are having some difficulties with setup up your router. We would love to help. Please send us a private message so we can assist you further.