Skip to content
dlodahl's profile

New Member

 • 

1 Message

Mon, Aug 19, 2013 7:00 PM

All emails sent from our domain to @comcast.net addresses are being filtered out as SPAM

Hello,

 

We are using Exchange Server 2003 and Comcast Business Internet Service, and are unable to send any emails to Comcast recipients. I have added a PTR record, SPF record, as well as setting the exchange server to use external DNS, but that did not fix the problem. As a test I logged into my personal Comcast account settings and completely disabled SPAM filtering, and these messages instantly start coming through. This is not a viable solution though, because we can't ask every client with a Comcast email address to manually change their SPAM settings. The domain name we send from is firstfidcorp.com. Is there a way prevent emails from automatically getting marked as SPAM? I have filled out a blacklist removal request, but it says our IP is not blacklisted.  Any help would be greatly appreciated.

 

Thanks

Responses

Administrator

 • 

1.5K Messages

8 y ago

Hello dlodahl,

 

Welcome to the forum.

I've forwarded your query to our support team for investigation.

 

Thank you

New Contributor

 • 

1 Message

2 m ago

Was there a solution to this question? I am having the same issue.

Official Employee

 • 

16 Messages

Hi, @user_a1f44c. Thanks for reaching out about your email issues. This thread is old and to better help and for system purposes, we would like you to make a new post in our customer service area with details as this thread will be closed/locked. Everything you have done to troubleshoot and any details relevant will help. Please also visit https://comca.st/3eaSZsW which has helpful topics about what to look for and also a form for blocklist removal. We are looking forward to assisting!