Skip to content
mk9pa's profile

New Contributor

 • 

8 Messages

Wed, Oct 6, 2021 8:04 PM

SOLVED: SMTP server, port, auth -- used to work, no longer does

I'm running a Linux mail server for our network with postfix as the MTA. For a couple of years I used Comcast's outgoing SMTP server which occasionally changed names. The most recent name was smtp.w14a.comcast.net, port 587, using my Comcast Business account username and password. For the past 2 years or so I've been using a different outgoing SMTP service but wanted to make sure the Comcast SMTP server could be brought in as a backup (for example, when the other SMTP forwarder is blacklisted).

Issues: smtp.w14a.comcast.net no longer exists. Googling around, it looks like there are a couple of possible replacements including smtp.comcast.net, smtp.businessclass.comcast.net, and a few others. I've tried many combinations of these (and other) servers, ports 587, 465, and even 25 (!!), and my Comcast Business credentials, and none work. Sometimes the connection fails or times out, in which case it's clear the server and/or port are incorrect. But even when I get a connection, like to smtp.comcast.net:587, it refuses to authenticate me using the Comcast Business credentials. And example log is:

relay=smtp.comcast.net[96.114.157.81]:465, delay=553, delays=552/0.02/1/0, dsn=4.7.0, status=deferred (SASL authentication failed; server smtp.comcast.net[96.114.157.81] said: 535 5.7.0 ...authentication rejected (LS))

I called Business Class Tech Support and the poor guy had absolutely no idea what I was talking about. He even claimed that Comcast doesn't  provide a service to send outgoing emails and I need to talk to my IT department (which is me). He eventually, after a lot of suggestions, went to ask a colleague and came back with the standard SMTP instructions I've found previously: smtp.comcast.net, port 587, "your Comcast account". But this isn't working, failing authentication.

(Update since OP) I enabled TLS logging and see that a verified TLS connection is successfully established between postfix and smtp.comcast.net, but the next step, authentication, is what fails.

Does anyone know how to get this working again? Or at least, what has changed and what to look at?

Official Employee

 • 

41 Messages

Hace 8 m

Hi mk9pa, thanks for creating a post. Can you tell me if you see the same issue while using a different mail host like MAC mail or outlook? 

New Contributor

 • 

8 Messages

Hace 7 m

Update: Solution found. But it was not obvious.

I talked to a knowledgeable tech support person at Business Class today. She said that Business Class no longer provided outgoing SMTP service, and I would need to log in to Xfinity.com and set up my web email, then use smtp.comcast.net. It turns out that because we subscribe to Xfinity TV, I happen to have an Xfinity account. That may not apply to others. It's possible that Business Class has its own web email, I don't know.

But still it did not work; authentication rejected. After more searching, I found the answer hidden away deep in the link tree of how to set up desktop clients. Xfinity has recently implemented additional security which requires each user to enable access to their email account from third party applications. Without this enabled, no access, incoming or outgoing, is possible from anything but the Xfinity web email. I had to go to my newly set up Xfinity email, click on Settings (gear wheel), then Security, and enable the check box for access by third party applications.

Now my smtp.comcast.net email forwarding works from the Linux/postfix setup described above: smtp.comcast.net, port 587, my Xfinity (not Comcast Business) email and password as account name and password.

This was not at all obvious.

(edited)

Official Employee

 • 

3 Messages

We appreciate you for sharing your update with us and others who may also run into the same problem, @mk9pa! I'm happy you were able to find a resolution that helped. Do you mind sharing that link so other can see and use it if needed? 

New Contributor

 • 

8 Messages

@Comcast_Che the link is https://connect.xfinity.com/appsuite/#!!&app=io.ox/settings&folder=virtual/settings/security but it looks to me like that may easily change over time. Log in, click on email icon at the top, click the gear icon at top right, select Security in the left column, and enable access through third party programs.

Official Employee

 • 

23 Messages

Awesome!  Thank you so much for sharing that with us here!