Skip to content
mrwinnie's profile

Visitor

 • 

3 Messages

Thu, Jan 2, 2014 2:00 PM

Internet Speed sucks.

I've had the Comcast 50/10 package for 3 weeks now. IM VERY UNHAPPY ABOUT IT! Im not getting the speed im paying for. Ive had them come out and check it now 2 times and they say its setup the right way. I am using OPEN lines with no upload/download limits and its no where 50MBps, its around 10MBps. Also, i can't have more then 2 computers using youtube before the internet is to slow to send an Email. I'm really thinking about dropping Comcast cause of this!

download test

Responses

Accepted Solution

Visitor

 • 

3 Messages

7 years ago

This is with only one computer hooked to the internet. Its a brand new network cable, so i know its not that.comcast test

Accepted Solution

Trusted Forum Contributor

 • 

113 Messages

7 years ago

The pictures youve posted all show the same server location. I got locked onto this, a local server here in Modesto was showing very slow speeds. Went outside the local one and all remote showed fast. Again show one that isn't Atlanta, GA

Accepted Solution

New Member

 • 

3 Messages

7 years ago

Forgot to add that they call my house and I have an IP Phone so they cannot get me.  I told them to call my cell and they never do.

 

Comcast - if you are monitoring this then call my cell.

 

 

Accepted Solution

New Contributor

 • 

14 Messages

7 years ago

Are you using a wired or wireless connection to perform these tests? If wired and you continually get the same results, I would call tech support on the phone directly.

 

The forums ARE NOT always the best solution to problems depending on the situation. Tell customer service to do their job and check your modem remotely and test your speeds. Sometimes there are bigger issues, and the external wiring has issues.

 

Bottom line, all this is fixable, but you need to communicate the problem to support. The forums don't always have a Comcast representitive replying. Many are just technical people like myself trying to help others for free!

 

1. Call support - get them to check your modem from remote

2. If you not satisfied, escalate and be firm by telling them you paid for the service

3. Ask for a partial or full refund for the period of inadequate service

4. Get a tech to come onsite if needed, but don't be surprised if he or she cannot fix the issue.

5. Get the tech to escalate

 

Finally, if your dissatisfied with their service, tell Comcast management via email or phone

 

This is the only way issues like this get better!

 

Good Luck

 

Robert

Trusted Forum Contributor

 • 

113 Messages

7 years ago

mrwinnie-

 

Can you post another speed test from another server in another location? Test from a few to see a consistent confirmation of your speeds.

 

Check your cable revisions and make sure there are no odd, bad network cables anywhere on the network.

 

If the "load" locally over two nodes causes a slowdown then it near confirms you have a local network problem (Something in the location, a PC with a faulty cable, faulty NIC, operating system that's streaming virusnessbaddies etc.

 

Your ability to "listen" and "hear" to a remote node can be caused by a local network issue (Something on "your" side). but can you do this?

 

Can you disconnect all CPE stuffs and test with a known-good network cable only to a known good PC and run a few tests to confirm if its a local or remote problem.

 

While you're doing this test, disconnect any devices connected to the Coax cable (A dish tv, a voip device) as if they are faulty they can feed back on the coax signal and drop your connection just as you've shown results for.

Visitor

 • 

3 Messages

7 years ago

I took these one after the other to show you its not the site. This is REALLY sad!

test one.fw.png

New Member

 • 

3 Messages

7 years ago

The internet speed that others are getting in this post would be awesome for me when I am only getting a trickle.

 

New Member

 • 

3 Messages

7 years ago

Welcome to Comcast.  I have been a customer for the past many years and consistently I have problems.  I wish FIOS was available.

It has been very very bad for the past 7-days.  Yesterday, I had to call 3 separate time because I got disconnect when ever they transferrred me to another person.

They are sending a tech out tomorrow but as before they will not find anything because they problem is in their network.  I say this because I have done tracert to different host on the internal Comcast network and the delay I am seeing is terrible.

The saga continues.

FIOS where are you?

Administrator

 • 

1.5K Messages

6 years ago

Post moved for better visibility.