Skip to content
lworxtech's profile

New Contributor

 • 

12 Messages

Thu, Oct 23, 2014 12:00 PM

Exchange server, delayed arrival of messages from multiple domains . . .

Hello, we’ve been experiencing unusual delays in delivery on our Comcast hosted Exchange service.
Our domain is “lauchlanworks.com”. It’s critical that our mail is delivered on time & a good many of the
users in the office are receiving mail almost a full day later than it was sent, on some occasions. The mail
is originating from various domains, so it’s not isolated to any one – even internal emails
(lauchlanworks --> lauchlanworks) are experiencing some unusual delivery delays though they are showing
as sent at the time they were sent. Some mail is timely, others are not – it’s all a bit random. This has been
the case for at least 3 days. Please help.

Thanks,
Brian

Responses

New Contributor

 • 

12 Messages

7 y ago

Using the provided Outlook 2010 or 2011 (PC / Mac respectively). Direct from the comcast server(s).

Problem solver

 • 

305 Messages

7 y ago

Are users accessing their mail directly via the Comcast site or using a third-party like Gmail to pull the emails? 

New Contributor

 • 

12 Messages

7 y ago

Also, I should add that the delays are present on the Exchange webmail, so it is not an Outlook issue - it's quite positively some issue with the Exchange server we are on.

Problem solver

 • 

305 Messages

7 y ago

I personally don't use this myself, so my knowledge is limited here. Have you tried calling Comcast and asking if they are able to see any issues? If they don't find anything you can request a request be sent to level 2 about it and they'll dig a bit deeper for you. 

New Contributor

 • 

12 Messages

7 y ago

Well, in the past when I've posted an issue here I've gotten at least one reply from a Comcast technical support person . . . that what I'm holding out for, though if none of them pipe-up soon I'll give 'em a call in the morning. Thanks for the input Kraze!