Skip to content
V

New Contributor

 • 

22 Messages

Monday, August 28th, 2023 8:50 PM

hotspots app

I'm posting this question here because I don't have a regular xfinity account to log into for help, just a comcast business account. Hopefully someone can help or direct me to right place.

The xfinity hotspots app on my phone (moto e 2020) won't let me sign in. I tap the option for business customers to sign in. Then I enter my email address and password and tap SIGN IN, but it won't even make and attempt to load the next page. What's really strange is that if I enter the wrong password, the bar at the top will look like the next page is loading, the screen will change for a second and I'll get a message that I entered the incorrect email address or password.

But again, if I actually enter the correct email address and password, nothing happens.

Also, I can sign into the app on other devices, just not my phone the past couple days.

Thanks to anyone who can help or point me in the right direction.

Official Employee

 • 

30 Messages

10 months ago

Hey there, that is definitely odd. Just to make sure I am understanding the issue, when you try to log in on your phone specifically, nothing happens, the page will not even load and this is a new issue, meaning this same phone worked in the past, and other devices still currently work? Did I sum that up correctly?

New Contributor

 • 

22 Messages

10 months ago

Yes. It sounds like you've summed things up correctly.

When I enter my email address and password, the progress bar a the top of the page just blips but nothing happens. However if I enter the wrong password, a new page loads and tells me I entered the wrong username or password.

And it stopped working Saturday, August 26.

Official Employee

 • 

43 Messages

Thank you so much for confirming that information @Vernon, so we can be sure we're understanding correctly. Have you tried uninstalling and reinstalling the app on your phone? 

 

New Contributor

 • 

22 Messages

yes, I've tried that.

Official Employee

 • 

43 Messages

Thank you so much for trying that @Vernon. To confirm, do you have the most up-to-date software downloaded on your device? 

 

New Contributor

 • 

22 Messages

It says I'm up to date. Android version 10, Security patch level: June 1, 2022. That must be up to date for my phone, moto e (2020)

Official Employee

 • 

43 Messages

Thank you so much for confirming that your phone is up-to-date @Vernon. Can I also confirm that you have the latest version of the Xfinity WiFi Hotspots app installed?