Skip to content
W

New Contributor

 • 

7 Messages

Tue, Sep 20, 2022 7:21 PM

VoiceEdge Portal Redundant Erroring

Here I am again... having to log in to the Comcast Business portal. 

First, I have to wait 3 minutes for the dashboard to load. Then, when I click on "users", I have a 50/50 chance that the page will load. If it does, when I go to find a specific user, the page fails to load or crashes.

Every time I call, I get asked to do the same things: if I use Firefox, I need to switch to Chrome. If I am on Chrome, they say I should use Firefox. Regardless, when it fails to load again, they ask to to clear cookies, cache, and history. Is it really necessary to do this every time?

Then, when I tell them I need to get going because we've been on the phone for about 20 minutes at this point, I get told that "they are working on updates this month and that is why the website is slow".

I've going through the previous process probably about 10 times in the span of the last 5 months. Even the businesshelp.comcast website works better than the admin one. 

Am I the only one that experiences this issue? All I need to do is change the caller ID on 1 phone. It should not be this difficult every time.

Official Employee

 • 

3 Messages

13 d ago

Hello @wirelessoperator. I am sorry to hear that the online portal is giving you so much trouble. Is the caller ID that you need to change for a business landline or a business mobile phone? I just want to make sure that we are on the same page here.

New Contributor

 • 

7 Messages

@Comcast_Robert​ Hello, this is for a business landline. The issue is not changing the caller ID specifically, the issue is getting the website to load properly. If I wanted, for example, to simply reset the voicemail PIN, I cannot get the website to load even that far for me without it crashing.

Official Employee

 • 

3 Messages

@wirelessoperator Gotcha! Thank you for clarifying that for me. Can you provide the link that you are using to gain access to the portal?