IPV6
Back to Top

Lost my IPv6 /56 this evening

SOLVED
Highlighted
drewhess
Visitor

Lost my IPv6 /56 this evening

Sometime around 6pm Pacific time this evening, I noticed some odd connectivity issues to certain sites. The problem appears to be that I lost my IPv6 /56 PD, as my OpenBSD router running wide-dhcpv6 dhcp6c is now only receiving a /64.

 

 

My IPv6 dhcp6c configuration hasn't changed for several years (haven't needed to change it, IPv6 has run great for 3 years at this site with the only hiccups being a couple of prefix changes from time to time). I did upgrade my modem to an SB6190 on Thursday night and also upgraded to Deluxe 250 service at the same time, but once the tech on the phone reprogrammed the new modem, everything was working great until now, including IPv6. (Neither my IPv4 DHCP assignment nor my IPv6 /56 prefix changed after the new modem came online.)

 

I've restarted the modem and have restarted dhcp6c on the router several times, but I'm still receiving a /64 from Comcast.

 

Can someone from Comcast help me get to the bottom of this? This has completely broken IPv6 connectivity at my site.

 

Thanks!

Accepted Solution

Re: Lost my IPv6 /56 this evening

Hi Michael, have you had a chance to make this change yet? I'm still seeing the same behavior on my end, i.e., still only getting a /60.

 

By the way, you can push this change any time you like as I'm out of the office for the next couple of weeks.

 

thanks!

View solution in context
Accepted Solution

Re: Lost my IPv6 /56 this evening

"IPv6 is basically unsupported for dynamic customers."

 

Don't worry, it is basically unsupported for static customers as well. I've had IPv4 static service since November and they still have not figured out how to allocate my /56 that shows up on my account to my hardware. 

View solution in context
Accepted Solution

Re: Lost my IPv6 /56 this evening

I have a novice IPv6 question regarding your problem.

I was reading about DHCPv6 and learned that most hosts receive their IPv6 addresses through stateless address autoconfiguration (SLAAC) (which uses ICMPv6), and only need DHCPv6 for things that SLAAC does not provide, such as NTP server addresses. (I read that DNS servers come from NDP.)

 

However, I also read that routers need an IPv6 prefix (and length), which make sense, so they know the range they can offer to hosts on their LAN. Is it true that SLAAC does not offer IPv6 prefixes, and this is why DHCPv6 is used? 

View solution in context
Accepted Solution

Re: Lost my IPv6 /56 this evening

Yes, neither SLAAC nor IPv6 router advertisements provide IPv6 prefix delegation. Only DHCPv6 does.

View solution in context
14 REPLIES
drewhess
Visitor

Re: Lost my IPv6 /56 this evening

I was able to get back to a /60 by configuring wide-dhcpv6 to specifically request a /56. With my SB6141, this was not necessary and I was given a /56 by default.

 

However, I'm still unable to get a /56 with the new SB6190 and my Deluxe 250 service. I would like to restore the larger prefix delegation if someone from Comcast can help me.

drewhess
Visitor

Re: Lost my IPv6 /56 this evening

After making a 3rd call to front-line support, I finally got Comcast Business Internet advanced tech support to return my call on this issue, several days after my original call and despite assurances that I would be called within 4 hours of my first report.

 

The tech I spoke with told me that there was nothing he could do to restore my /56 because, "IPv6 is basically unsupported for dynamic customers." He expressed genuine surprise that I was able to make any kind of prefix delegation work at all, in fact, despite my insistence that not only have I been doing that for the 3 years I've had service up until last week; but also that a quick Google search would reveal that so have literally thousands of other people, both Xfinity and Business Internet users alike.

 

Anyway, that was a deeply unsatisfying interaction. I have been recommending Comcast Business Internet to friends and coworkers for several years based on the outstanding service and competent technical support that I've received during my years as a customer, but I will have to seriously re-think that recommendation after this incident, I'm afraid.

Community Manager
Community Manager

Re: Lost my IPv6 /56 this evening

Hello drewhess and welcome to forums.

 

I apologize for the recent experience with customer service. Are you still needing assistance with your IPv6 delegations?

drewhess
Visitor

Re: Lost my IPv6 /56 this evening

Hi Michael. Yes, I am still not receiving a /56 delegation, only a /60. Is there something you can do to restore the /56 delegation?

Community Manager
Community Manager

Re: Lost my IPv6 /56 this evening

Unfortunately due to the equipment being owned by I am do not have remote access to its provisioning. I do have the option to push a temporary IPv4 only mode forcing re-registration to the network. That laps in time may allow the IPv6 routing table to push that delegation to a residential account in the neighborhood. I cannot guarantee that this will work and the process can take up to 40 minutes to complete. If this is something you would like to try please let me know when is best for you (AM|PM)

drewhess
Visitor

Re: Lost my IPv6 /56 this evening

Hi Michael, thanks again for your offer to help!

 

What's the worst case scenario here if this doesn't restore a /56 prefix? Will I still receive at least a /60?

Community Manager
Community Manager

Re: Lost my IPv6 /56 this evening

Yes you will, this change just speaks to the network with an IPv4 address for a short time. The network will notice you with that address and begin adding you to the table yielding at least a /60.

drewhess
Visitor

Re: Lost my IPv6 /56 this evening

Hi Michael,

 

That sounds great. I assume this is something you can schedule to happen automatically? Any time tonight (Friday) between about 6:30pm Pacific and 10:30pm would be fine. If that doesn't work, then anytime this Saturday or Sunday morning between 12:01am and 7am would work.

 

thanks!

 

drewhess
Visitor

Re: Lost my IPv6 /56 this evening

Hi Michael, have you had a chance to make this change yet? I'm still seeing the same behavior on my end, i.e., still only getting a /60.

 

By the way, you can push this change any time you like as I'm out of the office for the next couple of weeks.

 

thanks!

NVTech
Occasional Visitor

Re: Lost my IPv6 /56 this evening

"IPv6 is basically unsupported for dynamic customers."

 

Don't worry, it is basically unsupported for static customers as well. I've had IPv4 static service since November and they still have not figured out how to allocate my /56 that shows up on my account to my hardware. 

StarNet
Contributor

Re: Lost my IPv6 /56 this evening

I have a novice IPv6 question regarding your problem.

I was reading about DHCPv6 and learned that most hosts receive their IPv6 addresses through stateless address autoconfiguration (SLAAC) (which uses ICMPv6), and only need DHCPv6 for things that SLAAC does not provide, such as NTP server addresses. (I read that DNS servers come from NDP.)

 

However, I also read that routers need an IPv6 prefix (and length), which make sense, so they know the range they can offer to hosts on their LAN. Is it true that SLAAC does not offer IPv6 prefixes, and this is why DHCPv6 is used? 

drewhess
Visitor

Re: Lost my IPv6 /56 this evening

Yes, neither SLAAC nor IPv6 router advertisements provide IPv6 prefix delegation. Only DHCPv6 does.

drewhess
Visitor

Re: Lost my IPv6 /56 this evening

Still no /56, and now I don't even have a stable /60 anymore -- it seems to change every week or two. Sigh.

Forum Contributor

Re: Lost my IPv6 /56 this evening

Drew,

 

I have Comcast Business and I have a /28 of IPv4 and a /56 of IPv6 both static, assigned from Comcast.

 

The question I would pose to you is the following:

 

It is important to me to have static IPs.  (I run servers)   Because of this I pay a lot of extra money to Comcast for a business account so I can get them.  I ALSO get stuck with a modem 'rental' fee that Xfinity users don't have to pay for a POS cable modem 

 

How fair is it for a dynamic customer on Xfinity that pays less than I do for a lot higher bandwidth, to get the same static IP assignment?

 

Now, I would be the first to agree that Comcast should NOT be sticking it to us business customers up the wazoo for lots of extra money

 

But it seems to me that what is actually going on here is the same thing that old Ma Bell did - use us business customers to subsidize cheaper service for residential users.

 

Would you support raising residential prices a little so that costs between the tiers could be equalized?  I have t assume you don't support paying more money for business service already (since you aren't doing it)

Discussion stats
  • 14 replies
  • 3358 views
  • 0 kudos
  • 5 in conversation