IPV6
Back to Top

IPv6 just died

SOLVED
kevinmcmurtrie
Frequent Contributor

IPv6 just died

IPv6 just died a few hours ago.  It was working fine for months and, no, I didn't touch anything.  I don't have a router.  It's all devices at once (MacOS 10.6.8, MacOS Server 10.6.8, and Android 6.0.1)

 

All LAN devices can ping the modem.  The modem's diagnostics has full IPv6 connectivity to the LAN and external sites.  External IPv6 packets reach the LAN (I can seen ping packets from external test sites).  IPv6 packets from the LAN can not reach external sites.  All addresses check out as valid.  The Cisco modem is logging that the firewall is blocking IPv6 packets even when I completely disable the firewall.

 

Restarting the modem caused it to restart twice so I guess it pulled down a software update.  I've tried resetting just about everything and there's no change.  Customer support says they can ping the modem and that's good enough for them.  What's going on?  This causes websites to hang because everything thinks IPv6 is on.

 

pixelmemory.us is one of the machines that's always on and has an IPv6 address.

Accepted Solution

Re: IPv6 just died

I don't know what config Comcast pushed out to the modem, but it needed a full factory reset to work again.

View solution in context
5 REPLIES
kevinmcmurtrie
Frequent Contributor

Re: IPv6 just died

I don't know what config Comcast pushed out to the modem, but it needed a full factory reset to work again.

Highlighted
flybynight
Contributor

Re: IPv6 just died

I am having a bit more issues with IPv6 since the static configuration got rolled out. It looks like the DHCP leases expire quite quickly (about an hour I think). Once the DHCP lease expires, and if you don't renew it (my pfsense firewall doesn't for example), then your existing IPv6 addresses will no longer work.

 

You will see ICMP Type 3 Code 5 messages, indicating that your IPv6 address doesn't meat egress requirements.

 

This is kind of annoying. In particular with static IPv6 assignments now, it would be nice to just "use" the addresses without having to keep an active IPv6 DHCP lease.

 

My latest attempt to get this working is to setup a manual subnet with a larger lease time in my Netgear modem... so far so good.. but still waiting to see if it stays up a day.

 

 

 

 

flybynight
Contributor

Re: IPv6 just died

actually... didn't work. after about an hour it died again. Now I just setup a cron job to restart the dhcpv6 client once an hour. Lets see if that helps.

 

Community Manager
Community Manager

Re: IPv6 just died

Hello flybynight,

 

Please check your private messages for more information regarding this situation.

 

Thank You

Trent
New Contributor

Re: IPv6 just died

IPv6 is dead on my dpc3939b as well Smiley Sad

Discussion stats
  • 5 replies
  • 766 views
  • 0 kudos
  • 4 in conversation