Equipment (Modems,Gateways)
Back to Top

crippled comcast cisco router

SOLVED
Highlighted
rhashemian
Occasional Visitor

crippled comcast cisco router

hi there,

 

i have been having issues with my router as of late and have been in contact with support but seems like no one can help and it seems hopeless now.

 

here's the situation:

- have a server configured only with my static address connected to one of the lan ports.

- firewall is disabled for the static ip and server seems fine to outside traffic.
- wifi is enabled on the comcast router with dhcp which assigns 10.1.10.x addresses to my devices.
- i have always been able to access my server's services (http, smtp, ssh, etc) from my 10.1.10.x devices.
- i have been able to access my server for years from my old smc router and the new cisco dp-xxxx one.
- apparently a couple of weeks ago my router was firmware flashed and i can no longer access my server from my devices.
- sometimes i can access http from my 10.1.10.x devices but first i'd have to ping the server first and then i'm good for a period. then dead again.
- this has all the signs of ids (intrusion detection) being the cause of the problem.
- in fact when i look at the 'firwall security level' choices, all have IDS enabled now and no way to disable them.
- a support tech tried to revert the firmware for me but the router went right back to the updated firmware.


i am paying for this router every month and it is crippled. please, can someone help?

 

Accepted Solution

Re: crippled comcast cisco router

i was finally able to resolve this issue myself by creating a static route on the server to the private lan

(on the nic that is wired to the router). in my case on my linux server:

 

# ip route add 10.1.10.0/24 dev eth0

 

and then made it persistent to survive reboots.

 

never had needed to do this before, whether on the older smc router or the current cisco one. so still pretty sure some change at comcast caused this, flashing new firmware, changing network config, etc.

 

maybe this will help someone.

View solution in context
Accepted Solution

Re: crippled comcast cisco router

I have been experiencing very similar issues and more. Besides the connectivity issues between static ips and 10.1.10.x devices, now I cannot see the list of connected devices in my router, nor can I assign a reserved ip to a device (I always get an "invalid ip address" error), etc. The router used to work fine when I got it a few months ago, but now its seems to have lost much if is functionality.

View solution in context
3 REPLIES
rhashemian
Occasional Visitor

Re: crippled comcast cisco router

i was finally able to resolve this issue myself by creating a static route on the server to the private lan

(on the nic that is wired to the router). in my case on my linux server:

 

# ip route add 10.1.10.0/24 dev eth0

 

and then made it persistent to survive reboots.

 

never had needed to do this before, whether on the older smc router or the current cisco one. so still pretty sure some change at comcast caused this, flashing new firmware, changing network config, etc.

 

maybe this will help someone.

mlerma
Visitor

Re: crippled comcast cisco router

I have been experiencing very similar issues and more. Besides the connectivity issues between static ips and 10.1.10.x devices, now I cannot see the list of connected devices in my router, nor can I assign a reserved ip to a device (I always get an "invalid ip address" error), etc. The router used to work fine when I got it a few months ago, but now its seems to have lost much if is functionality.

mlerma
Visitor

Re: crippled comcast cisco router

This solution also worked for me, thank you! - although certainly I don't see why we must do this now if it was never needed before.

 

My router is still experiencing other issues (like not showing connected devices)...

Discussion stats
  • 3 replies
  • 914 views
  • 0 kudos
  • 2 in conversation